Download

question about uniformed grids

Working on trying to get the backgrounds of the uniformed grid to show like there suppose to. the slots on the inventory all have a button that is suppose to fill the slot which is all aligned up in the umg editor but when i go in game there all collapsed and i cant seem to figure out how to get the to reappear. only way for them to get 1 slot to show is if i pick up a item. which looks ugly. heres a screen shot of what i mean.

this first shot is what it looks like in game.

grid issue.png

the next shot is what it looks like in the umg editor and what its suppose to look like.

griddiusse2.png

and this is what it looks like when you pick an item up in game.

so im wondering if anyone has ever had this issue and if so if they know how to fix it cause im pretty much out of ideas ive set everything except the panel im using to visible and im still not able to get the buttons to show correctly.

any ideas on how to fix is this is very much appreciated.

Hello,
I am really sorry for you because i would be really sad for me if i was in same trouble :frowning: I can only give ideas as i haven’t work a lot on umg and since last changes i see that i need update, but i wonder if both background and buttons are not set directly in grid instead of having background set in grid and button set in background (and pic in button) and that the difference could be generated by the need to have different settings of image fill and spacer value (which may be the origin of the diffrence of height for both. In hope those ideas help you investigate more.

Hmm, what version is this? Also can you post some more shots of how your container and the items are setup? Would like to see what the widgets are that fill each slot.

this is version 4.6 the set up is the same as this https://www.youtube.com/watch?v=RQm6cm05SLc&index=7&list=UUBobmJyzsJ6Ll7UbfhI4iwQ ill post some screen shots here in a few mins

first is the slot button

number 2 is the image on the button

number 3 is the button in side the grid all 50 buttons have same setup

number 4 is the grid it self the vertical box is set to hidden by default but grid is set to visible

the next 3 screens are of the blue prints for the button

next is the slots on the inventory side of things

and last 2 screens iof the item blueprint that deals with slots

item one probally has nothing to do with ti since this is an issue with the connection between the icon and inventory but i figured id post it anyways

same thing is happening with my hotbar and my spell book i just made so i must be doing something wrong.

Issue resolved.

Oh? - do tell

+1 ^^

Please !

one of the dumbest things you can think of and something i didnt even think to even check till this morning but i didnt set the slots to fill which makes them shrink in game. after setting them to fill they worked perfect. only issues i have is since i have to set them disabled i cant find were to change the greyed out effect the slot widget it self has had all its buttons styles changed only thing i can think of that causes this is the fact that the image on top causes this effect and i cant figure out how to fix that. since theres no settings for stuff thats disabled. unless there is and i havent looked hard enough.