Question about Skeletal Mesh Character, automatically falling to the ground when I hit simulate

Hello guys,
i´m new to UE4 for writing my bachelor thesis and experimenting with physics. I am using UE to test the behavior of ragdolls. Therefore i created a mesh in makehuman, imported it in blender and exported it as FBX file to Unreal. Then i created a Collision Object (Car) and wants it to hit the Character i placed next to it. Everything works okay, but i have 2 problems:

  1. My Character instantly falls to the ground when i hit simulate, so when the car hits him, he is half laying on the ground. For my purpose its pretty annoying, but i cant help it. I thought there was function like “start deactivated” like there is in Blender. I discovered some options like a tickbox start awake, but its not changing anything.

  2. I have a problem to scale the auto generated bodies in the PhysicAsset. It looks like i am not able to scale them down to the right size, so i googled and some people said that the problem is the size of the boxes or the scale options. My Character is 3m+ high so i would say this is not the problem and i tried a scale of 0.00001% which couldnt solve it either.


I have no idea… I attach pictures, i hope u can help me guys. Thank u in advance!


1 Like

Easy way is to create a bluepring from the skeletal mesh (or containing the skeletal mesh).

Then add a collision detection sphiel, larger then the character. set it to Overlap All.

in the details panel for the collision capsule, scroll all the way down to the event and click the + next to OnOverlap

From there you can take the overlapped actor, make sure it’s the car, and if it is (branch) enable physics on the actor.
Yes, you will start to rag-doll immediately, but hopefully the impact will be fast enough that the short amount of time won’t matter.

Hallo [USER=“3140864”]MostHost LA[/USER] ,

first of all thanks for your answer! It took me a while but i think i understood where you are going. Now i have the problem that i am not able to set this up correctly. I came this far but something seems not to work or i missunderstood.

Static Mesh is the car and Skeletal mesh is the ragdoll. I made the sphere so big that it contains the guy and then changed it to not visual.

I hope you can help me again, but i am already really thankful!

So, the sphere doesn’t need to be excessively big or a sphere.
depending on the position of the guy a sphiel (cylinder with rounded ends) also called capsule may be a better option.

Anyway, now that you have the overlap event you can detect what is overlapping.

Depending on where you are in blueprint wise - level, a blueprint etc - you can choose which blue pin to use.

In this case I believe other comp may work.

Click and drag and type Equal.
In the second pin for it you can probably connect the static mesh.
the boolean pin can then go into the branch.

Not sure if physics blending is the right node to enable physics. But you can always try another node out if it isn’t.

Hey its me again. I connected everything as you (hopefully) meant it but its still not workling. I cant find the mistake, do you have any idea?
It loos like this now:

I added the false -> deactivate thing for i’m desperate :smiley:

is the execute pin from the On Component Begin Overlap connected to the branch? It has to be in order for the branch to execute.

As far as the deactivate goes, I’m not sure that’s what you want.
The deactivation should probably be set up on the mesh itself based on the current iteration count of the physics simulation / if there is movement or not.

Check stuff like this for hands on training

Did you ever fully figure this out? I am having a similar issue when trying to create a player with a skeletal mesh. There needs to be gravity but I do not want the character just falling to the ground like he has no muscle to support himself. Not sure what to do here…