Download

Question about Normal maps and UE 4

Hey guys,

As the title says, I have a question about normal maps. I migrated from Unity to UE 4 recently and for some reason my normal map looks a bit strange in UE. Here is a screenshot showing what I mean. The Lion on the left is UE and the one on the right is from Unity. The normal map was baked in Xnormal and the model came from Blender. When I imported the model I made sure to check “import normals and tangents”. Is there some procedure such as flipping a channel that I don’t know about?

Lion-Head-Comparison.jpg

Definately looks like the plane behind the door knocker is flipped (normal direction that is), as the rest of the model looks fine. If you try using two sided mat im sure it will look ok but the best thing to do is to import it into a 3d program and make sure the normals are facing the right direction.

Thank you for taking the time to reply Ghiest!

The door itself I am not too worried about as it doesn’t have its texture yet. In fact, the door looks pretty normal with the normal map on it (haha no pun intended). I also made sure the normals are facing correctly. One part of the door knocker that appears off to me is the big black spot on the lion’s nose. The light source is currently coming from top with a slight angle. I guess its also worth mentioning the lion’s UVs are overlapping but I baked the normal map without overlap.

Try flipping the Normal Map green channel. I’ve read on numerous posts of this being the problem with importing Normals maps into UDK. Select the green channel in Photoshop…Go to Image>Adjustments>Invert

You can do it inside of UE4 as well. Double click your normal map texture and there will be a checkbox on the right side to flip the green channel. It definitely looks like a green channel issue here, I agree.

Good tip Warren, thanks!

Oh excellent! Yep that was the issue. Thanks PuckerFactor. Also, thanks a lot WarrenM for the tip on using the UE editor.

If possible could we get a before and after shot for comparison on how flipping the green channel actually fixed your issue?

The gist of it is that the values in the green channel of your normal map control the up/down vectors. When it’s wrong, light appears to be hitting the mesh from the wrong direction. When you flip it, you reverse that lighting vector information, and suddenly everything looks “right”.

If Killer Ferret posts an “after” picture, you’ll definitely get it!

Fair enough, thankyou for the further explanation :slight_smile:

Sorry for the late reply, its been a busy weekend.

Here is an example of what it looks like with the green channel flip. Just like what Warren said, if any of the color directions are wrong to what ever program you use, the lighting for that direction will look strange or backwards.

0da287dec08df634b98fff6a193af99204a0aaeb.jpeg

Thank you for taking the time to do that.

It helps to have an example to visualize the difference.

No worries :slight_smile: I agree its usually better to see something visually than just having it explained.