Download

Question about materials

So, first of all, hello everyone :). This is probably my first time using unreal engine 4 (or unreal engine at all for that matter, except for some initiation on UDK). I have a completely silly question regarding materials and normal maps.

I got myself a texture and created a normal map texture using knald. On Knald, it looks like this (I know, it looks bad, I’m just learning the engine, please bear with me.)

http://i.minus.com/iGYULiyy8qamv.jpg

On UE4, though, it appears like that:

http://i.minus.com/ixaLxM7aP05fM.jpg

As you can see, I used the color map, normal and AO. there are 3 more maps created by knald that I dont know where to place it. Is there a way to create that on UE4? Am I just talking silly stuff?

If anyone could point me in the right direction about what am I doing wrong and / or some tutorials regarding material creation. That would be great.

Thanks in advance :slight_smile:

Make sure you set knald’s coordinate system to Y-. If you don’t do that, the normals in UE4 will be in the wrong direction.

Let me know if this helps :slight_smile:

I’m not sure what you mean, if you could explain more please?

Are you trying to place multiple textures on a single mesh? If so that’s not done in the material editor. I can explain more but I’m not sure if it is what you mean.

Something is wrong with your normal map. What format is it? And is its compression set to Normal Map?
Also you can flip the green channel inside Unreal and see if it helps.

do you mean here?

http://i.minus.com/ibmjwf4lEwP45D.jpg

If so, I just did. Nothing so far.

No, I am trying to create a material with textures, I mean. The Color one, normal map, in a way that I can achieve a similar effect that the one on Knald.

I exported it as a PNG also as a TGA 16bit. Am I doing something wrong here? How do I set its compression to normal map?

It should be 8bit. You can see the compression settings on the right panel when you open a texture inside the editor.

Inverted Y, saved as TGA 8bit and still looks weird

Ok, one last thing…change Mip Gen Setting to FromTextureGroup

Yeah that’s what I meant. Sorry it didn’t help :frowning:

Hmmm, I think I got it.

Here’s the issue, when I import only the normal map to knald, here’s what I get:

http://i.minus.com/ibdWyW80C76MF7.jpg

Technically, it is correct. It shows only some stuff. The thing is: Knald also has these options-

http://i.minus.com/ibgGHQNqG1gcdm.jpg

Is there a possibility that the information I need to create those kind of bumps on my material are stored on those 3 options?

I’m not exactly sure what you are after, but do you want to displace the mesh as it is in Knald? If thats the case you need to create its height map to use it for tessellation.

I don’t think so, those are just other maps, unrelated to normal. Your saved normal map you posted earlier looks good, there must be a setting in UE4 somewhere that is messed up. I’m not too familiar with UE4’s materials yet, so I’m afraid I can’t help you there, sorry :frowning:

YES, Exactly that!

Now I just found out my texture isnt a power of two or something, so yeah that might be also causing some issues since I am not able to properly import the heightmaps

Ahh, yeah that was another problem then. Non-power of two textures use no mip maps and end up looking noisy all the time.