Quest Extension Plugin appears to Install on MAC, but doesn't.

The Plugin Quest Extension Quest Extension in Code Plugins - UE Marketplace installs and works fine on PC, but when I try it a MAC it appears to install fine and even appears in the plug-in manager (see screen shot), but none of it appears to actually work or show up in the editor. I’ve contacted the developer of the plug-in and they are at a loss as well. I’ve tried this on both 4.18 and 4.19 and it fails on both.

Shows up in Plug in manager

But is absent from the editor itself (in the “create advanced asset” section, below miscellaneous there should be a new line called Narrative, but its missing on MAC:

Also, when reviewing the log, there is no mention of “Quest Extension” at all, even though it then appears in the plug in manager as enabled. Already tried restarting/reinstalling/etc. Again, this all works swimmingly on PC.

Would really appreciate any guidance on this as this is completely roadblocking Development of our MAC client.


I don’t understand why this would be happening, so I cant really offer any advice on this other than checking the obvious (correct engine versions etc), but I’m sure you’ve already done this.

However, have you looked in the ‘Miscellaneous’ folder? That’s the usual location for additional items so perhaps there is some differing functionality on different OS’s (Although again, I don’t know what that would be).

If it’s not there, try Miscellaneous->Data Asset and see if you can select Narrative within that (this assumes that Narrative is a Data Asset, which it might not be - I don’t know the plugin)

Finally, if you are comfortable with C++, have you tried rebuilding the project? This will require taking the plugin out of the Engine install folders and putting it in your own Plugin Folder. You’ll then need to generate the XCode source files (right click on the project) and finally rebuild the project.

Hi , thanks for the response.

Yes, correct engine version. Doesn’t show up in the misc folder. It’s not just the UI pieces that are missing, even the Blueprint components are missing as well. Nothing in the miscellaneous folder either.

You’re C++ idea would probably work, but I’m not confident enough in it to try.

It’s all very odd because it installs very easily on the PC, but is a complete ghost on the MAC.

Anyone else have any ideas or is using this plug in successfully on MAC?