Hey Dannington!

That’s a good question - I’ve just tried to recreate the example and it seems to work fine, can’t get it to crash as long as the URL is valid (including trying to get non-existant keys from the post data)… Does it work with the test URL? Does it display any errors? What version of UE are you using?

Cheers! :slight_smile:

I’ll check a bit later - thanks for the plug-in by the way - I hope I can contribute to the forum at some point in the future.

Hey Stefander, the plugin is working as intended! I do however have one problem. From the Get Request node, I promoted the Return Value to a variable called Request. Then I can’t assign it as the target for Bind Event to OnGetResult. What variable type should it be? I get PageData when promoting and no matter what I try, I can’t set it as target.

Do I have to create a special type of Blueprint for this? I used Level Blueprint for testing this.

I missed that I had to drag out a connection from the variable and choose Assign from context menu. Problem solved. :stuck_out_tongue:

Now I tried it again in another blueprint and I can’t bind the event again. Is there something I am missing?

Works again after restarting the editor. This is very weird behaviour. Happens with the VaRest plugin as well.

So finally some results. I can get what hat my character should wear from my local server. Great plugin! :smiley:


I did notice a bug though. If you type a URL without http:// you get an editor crash.

Hey Denny, cheers, means a lot!

I just noticed any non-valid URL will cause the editor to crash - I’ll look into it as soon as I finish the latest work due for Looping Louie (yay!), hopefully that should be in a few hours! :smiley: If I find the bug I’ll report back here!

Thanks again and if you run into any other troubles, let me know! :slight_smile:

I’ve just uploaded a new version that should be a lot more stable, turns out it was a stupid error on my behalf, sorry for any troubles the crashes might have caused any of you! :slight_smile:

Does it work with the 4.3 preview?

Not sure about 4.3, but if it doesn’t, a recompile should fix it :slight_smile:

Confirmed, doesn’t work with 4.3 because the engine detects it being compiled for an older version.

Stefander, thanks for this, super thanks. I think it’s just what I need for my project. I recently attended a webinar with Cloudant regarding the potential to scale for potentially heavy data requirements should the game we are building take off. While we are busy building assets and game play, we are just starting to investigate data issues. Cloudant works with Data Stores, if I understand your contribution correctly, this is the type of functionality your plugin is offering. I should apologize for this noob question, but hope you’ll help anyway. Cloudant has free trial accounts if you could investigate, though I will explore this soon too. Finally, will you be maintaining a freshly compiled version from UE build to build?

@KillerSneak & @Denny: Cheers guys, updated the zip with x64 binaries for the 4.3 release! :slight_smile: Sorry for the delay!
@jwise: Thanks for your interest man! This plugin doesn’t require any specific backend setup, all it needs is a valid URL that returns data! So I’m pretty sure you can make Cloudant work without modifying this plugin :slight_smile:

Keep up the good work. :slight_smile:


Thank you for your efforts but I can’t download it.

Anybody can help me?

I got the below message from the URL

@ckyun777: I accidentally made a rar instead of a zip, rookie mistake, changed the link, hope that helps! :wink:

Let me chime in and say that you are an awesome person for making and sharing this for free! This means a lot! As web developer I can setup up a webservice that will let me persist my data! THANKS!!!

Hey Irakli, thanks for the kind comments, the pleasure’s all mine! :slight_smile: Let me know if you have any issues!

Just to let you know your plugin doesn’t seem to work when it get’s packaged. No idea why, it just refuses to do anything or I’m running the game wrong but I don’t think I am.

That’s a general issue with packaging though, this workaround might work for you, let me know! :slight_smile:


Will you get time over to do a recompile for 4.4 on this great plugin?


Sorry for the delay - it’s been crazy busy!
Here’s are updated binaries for 4.4: http://www.stefander.nl/files/JSONQuery_UE4.4.rar
Let me know if you have any more issues!

It’s not working in 4.4.2, I suppose at some point I’m going to have to suck it up and compile my own build but oh how I hate that. I’ve recently had the same “Module” error where version numbers aren’t matching.

I’ve compiled the binaries with the 4.4 branch on Github since I thought that was the newest ‘mainstream’ version (haven’t had enough free time to toy around more in the last couple of weeks)… Sorry about that man, I agree it’s a bit annoying :slight_smile: