"Pure virtual function being called while application was running (GIsRunning == 1)."

Copied above is an error that I’ve been plagued by in my Blueprint-based project. I haven’t created any C++ files, or tampered with any that were there. The error only pops up while running the project in “Standalone Game”, never within the editor window, and occurs when I open a new Level. I’ve attached the popup to this post as the first image.

Based on the wording of “pure virtual function”, I started by going through each of my child Blueprints (BPs that use another BP as a parent) and making sure that only implemented Parent functions are called. Basically, if any “Parent: {function}” nodes exist, I made sure that the related function in the Parent BP had logic of SOME kind that it runs (even trivial), and/or removed the calling node from the child.

This greatly reduced how often the error appeared, and I thought I’d patched it. However, after packaging and exporting my game, my playtesters reported seeing the error as soon as they loaded a level past the one they spawned into and that it completely crashed the game.

Anyone who has a fix for this would be greatly appreciated.
I’ve attached the error as it appeared to me in-engine and as it appeared to my playtesters.
I’ve also attached both instances in my code where a new level is opened. Both of these seem like simple function calls to me, but something may be wrong about them.

Pure Virtual Function Bug
Pure Virtual Function Playtest

1 Like

Try deleting config folder

The editor crashes trying to load the project without the Config folder. Thank you still.

One of my first attempted solutions (gathered from here) was similar to this, involving deleting the Binary, Intermediate, and Saved folders.
None of those worked either.

Do you have a default map set?

Same here.

I’m not sure what it is the your case, but for me issue was caused by PaperZD Plugin’s Anim Instance. I still don’t know root cause of issue but in my case workaround was to set Anim Instance for render component of PaperZD Character blueprint manually with delay in begin play.

1 Like

I apologize for going so long without checking this forum. Yes, the project has a default level set.

I’m not using Paper ZD at all, only Paper2D flipbooks, tilesets, and widgets. Thank you anyway.

I’m still looking for solutions.
Today I disabled the Tick-related boxes in each of my Actors that lacked an EventTick() node. That is, in the “Details” tab for those Actors I turned off the options such as “Actor Tick”. Seems like a step in the right direction, though it hasn’t patched the issue.

1 Like

I solved it by removing Flipbook from Source Flipbook in Sprite.

Unfortunately this didn’t work for me, but thank you for the lead still!

@MrStarman18 Any luck on finding a solution? I am running into the same thing with my project, similar set up. Blueprint only, haven’t touched C++ files, it happens only on level loads.

I’m using Paper2D as well as PaperZD but none of the solutions in this thread worked for me either.

1 Like

No, sadly still no solution so far.
Which sucks, it really does.

@MrStarman18 I also tried everything but then I changed the engine from 5.2 to 5.3 and the problem was gone.

EDIT: It is not solved, sometimes it still appears but not every time as before.

I use Paper 2D without the PaperZD plugin.
I encountered exactly the same problem when calling the Open Level function. And I came to the conclusion that the more Blueprints Classes at one level, the greater the chance of causing a critical error.
Solution: Optimization using Level Streaming and reducing the number of BP Classes by one level.

I apologize in advance for my bad English.