Purchase failed on marketplace

Why i cant purchase item on Marketplace?

It says

Error Code: E80-3210-0.

I have suciffient money on credit card and also tried to raise purchase limits, but no effect.

So problem is somewhere else… :frowning:


Hi lukas84,

Where are you located? We are currently aware of an issue with this error code dealing with different currency types in some European countries. It is being looked into and we hope to have it fixed soon. If this isn’t the case, does the error give you a block of text as well? If so, please post that too.

Hi TJ.

You almost guessed it. I am from Czech republic which is next to Poland. We have CZK (czech crown) currency.

But i thought that credit card payments are universal and available accross world, automatically converted. (Or may be not so automatically :P).

But i am able to pay UE subscription so thats bit strange… (with same payment method…) may be you have another payment gateway for that? Strange.

Secondly, i always saw the prices in marketplace in $, and recently i see them in euro (and it seems to me that they are higher :/).

I dont see any other text, only this error code…

Anyway please fix it…

Thank you


Thank you for your patience. We are actively looking into this and we hope to have it corrected as soon as we can. We will post back asap.

Thank you very much :).


Hi lukas84,

You should now be able to make purchases again. We’re sorry for the inconvenience. If you would like to know a little more about why the issue occurred, please take a look at the post below.



amazing! :slight_smile: thank you very much :slight_smile: i will purchase and check the link.


it worked! happy