Download

Puking and crying trying to do a simple import

Can someone give me some pointers on what I could possibly be doing wrong? I’ve imported 100’s of models but for some reason this one refuses to work and it’s making me feel insane. I have the model + animation running BEAUTIFULY PERFECT in blender and then it just refuses to import to unreal. I get varying issues from the entire dress missing if I import as fbx. In gltf I get “duplicate rootbones found renamed to rootbone 01” I’m guessing this is because the dress and body are two different objects in blender. I’ve tried merging them. ive tried renaming multiple rootbones in blender. just NOTHING WIILL WORKKKKKKRKRKRKRKRKRKRKRK

Model : Sci-fi Girl v.02 Walkcycle Test - Download Free 3D model by patrix (@patrix) [07ac452] - Sketchfab

Also 5-0EA is not counting as a version tag that is required to make this post…Somewhat frustrating

Getting it imported fine with animation but the dress isn’t importing. I’m getting this message ^ in the logs. “No hierarchy node for mesh” I guess I need to add a hierarchy node for the dress but not entirely sure what that means in blender

I don’t know if this will help, but when I had a problem with missing parts, it turned out to be a problem with the normals. I just had to recalculate them in Blender and then the objects imported fine.

Yes, it seems there are 2 different objects in blender and the dress animation is defined in a way that doesn’t get exported properly.

1 Like