Download

Publishing mods not working

Hello everyone!

I am having trouble uploading my mod to the steam workshop. The mod is tested locally and on a dedicated server and works just fine.

After cooking it, I get a “132456789.mod” file and a “123456789” folder plus a folder containing my cooked assets.
The big problem is that the upload button does not get enabled!

I have tried to upload the mod manually using steamcmd with limited success.
Turns out that I can not modify the modfiles manually to change the appid to the actual value without invlidating the files (**** checksums).

I have been working this for 3 days now and can not get it to work.

So far i have:

  1. downloaded the Ark DEV Kit using the Epic Games Launcher

  2. accepted the workshop agreement

  3. created my mod and tested it

  4. cooked the mod as game mod

  5. not been able to upload it using the dev kit

  6. moved my assets into the 123456789 folder

  7. checked that the 123456789.mod file and the 123456789 folder with all the rest (assets + mod.info + modmeta.info) are located in the C:\Upload\Content fodler

  8. started steamcmd, logged in

  9. executed the workshop_buiild_item command with the following vdf file:
    “workshopitem”
    {
    “appid” “346110”
    “contentfolder” “C:\Upload\Content”
    “previewfile” “C:\Upload\preview.png”
    “visibility” “1”
    “title” “MYTITLE”
    “description” “MYDESCRIPTION”
    “changenote” “Initial Upload”
    }

  10. wondered about the fact that the command does not change the 123456789 to the actual appid

  11. copied the content of the ark dev kit git into the installation wiothout yielding anything

  12. eathen a lot of candy to calm the nerves

I would be very happy if someone could help me get my mod into steam. It is ready for the rest of the world :slight_smile:

regards,
elunder

You’re not allowed to make your own appid number, steam will give you one the first time you upload one to steam.

Simplest thing for you to do right now, make a new empty blank mod, cook & upload it. Go and find the appid, write it down.
Edit your ARKDevKit\ModTools\ModConfigs\ModFile.vdf file and take the AppId from the blank mod, and set it in your not blank mod.
open steamcmd and workshop_build_item ARKDevKit\ModTools\ModConfigs\ModFile.vdf

To “enable” the upload button, delete the path from the test-cook directory, and cook your mod again. The reason it’s not enabled is because if you haven’t filled out the required fields(image, title and description), and you’re only cooking through the test output, then your mod has not been cooked to a format that is usable by Steam, the Workshop, or the Linux OS.

-WM

Thanks for the quick responses! I did use appids that were thored in the vdf files, but the binary mod files still referenced the 123456789 ids. That was the real problem.
Removing the test output directory did the trick… I was trying to upload the test output over and over again!!!

Thanks a lot! This was epic help!