Download

PSA: Some applications with on-screen displays can cripple editor performance

If you’re getting poor performance in the editor I highly recommend taking the time to go through any applications and background services you have on your system that have on-screen displays and try disabling them.

In my case I went from having 100ms+ frame times while using the editor to a flat 8ms by disabling the startup of “Sonic Studio 2”, an application that came with my on-board sound driver.

Here are videos showing the difference it made with it enabled and when I had disabled it. Aside from the fps drop there was considerable mouse “lag” making interacting with the editor a chore.

Applications that are reported to cause this issue are:

If you encounter another application that causes similar issues please post the applications name so I can add them to this list.

NZXT’s CAM causes editor lag/crashing too. - Editor crashes when using Shift+O - UE4 AnswerHub