Download

PSA: Linux Unreal Engine 4.7 - community branch available

I had this crazy thought that during GDC 2015, with all the interest in UE4 that will happen, there would be people out there who might want to try it in Linux, too. :slight_smile:

Since official epic/4.7 doesn’t contain “the best of” (some important fixes couldn’t make it from epic/master into it) for Linux, we have decided to put out a Linux community branch of UE4.

This branch, named 4.7-linux, is available from my repo (https://github.com/3dluvr/unrealengine) and contains some of the needed improvements and fixes that make the Editor in Linux more presentable to general audiences and first time users.

It is my hope that we could gain some traction during GDC 2015 (and after) and draw attention to UE4 being the only commercial AAA engine natively running in Linux (hint: if you want to promote or showcase this around Social Media, and other websites, you will be doing a service for the community :smiley: ).

Shout-outs go to: yaakuro (for picking up the ball and making the needed fixes to SDL and Linux portion of the Engine); salamanderrake (for his relentless pursuit of IDE support and C++ project generation/compiling); Epic|rcl (for helping out and putting up with us in IRC #ue4linux); and others who have contributed in one way or another.

P.S: If you need hands-on help with anything Linux UE4, come by IRC #ue4linux on Freenode Network.

I’ll see if I can get our game running in Linux. Last time I tried I got some build errors because a certain Mono version could not be found, even though I had 3.x.x

I want to experiment with the engine, is the UE4 available for Linux? Or only games made with it?

The Engine is available for linux, as are games. The only thing with the Engine its self is as far as I know you still need to build it from the source code which is available via GitHub, there is information about here on the forums and in a few other places. I’ll check to see if I can find you some links after work but ya should be able to find some thing relatively easily :slight_smile:

@amigo - Great idea, I didn’t realize there was a community branch of the latest at all. I’ve always planned to support Linux but haven’t dived into it yet since I also have to support the Oculus Rift SDK.

Thanks, I did this for the reasons you mentioned:)

I had some problems:

I use Clang 3.7 built from the current master, and because of that I needed to add ‘-Wno-inconsistent-missing-override -Wno-unused-local-typedef’ to the build flags in LinuxToolChain.cs

SDL was built without GCC_ATOMICS and without SDL_WITH_EPIC_EXTENSIONS, the editor hung during the SDL Initialize call while trying to acquire a lock.

Some minor compile error/warnings needed addressing (Clang being picky).

After fixing these, the editor worked just fine. I launched the flying template before typing this up.

Thanks for the good linux work, and of course the engine as well:)

Awesome job amigo … I am going to give this a go when I get back from work. 8-}

Thanks!

The more help and awareness we can get/make, the better. Sooner we will see the Editor out for Linux, officially. :slight_smile:

There’s no work on Clang 3.7 yet, afaik. We know that 3.3 and 3.5 are working and that’s what we are telling everyone to use.

great idea

thanks for the heads up and the hard work.

Bumping this as I want to keep to my promise! I’ve gotten new and faster PC, and figured it’d be a nice opportunity to test out the Linux functionality of the engine. Lo and behold, it worked without any issue; our game runs flawlessly! This was even on the master branch of Epic, instead of 3dluvr’s fork.

Imgur

Even running 6 clients work at the same time, hehe.

Imgur

Hi guys,

It seems that developer repo suddenly became unavailable - 3dluvr · GitHub - 3dluvr doesn’t have any repositories you can view.
Has it been moved somewhere?