Provision key not found

I have seen some posts about this, but I am still not getting my project to recognize provision key. I can test it fine on a ipad, but when I want to package it, it doesnt find signing key.

I followed all steps from documentaiton website, I revoked all certificates and provisioning and retried. I even downloaded WWDR certificate from apple and instaled it. Still doesnt find provision key. Is there any successful way of packaging atm?

I noticed I am not only person with this problem, as seen here:

Did you remove expired WWDR certificate?

I have tried that now, I removed all my old certificates as well, replaced with new ones, still gives me “Provision not found”. I have revoked all my old certificates and created new ones as well to see if that was problem, but it still doesn’t work.

Could you please look into this Epic? I need to deploy my game to appstore and until this is fixed I am unable to do anything.

Hi ,

We have someone looking into it, and they’ll post here with questions when they can. Thank you for your patience.

Thank you very much! I’ll be waiting.


Could you please provide me with screenshots of how you’ve set up platforms - iOS settings in Project Settings? Can you also tell me what platform you’re packaging from?


Hello! Many thanks for looking into this! Not sure if this is what you need, I blurred identifier as Its something that should not be shared in public I think (if you need it as well Ill send in PM). Im using windows 7 pro, ue 4.10.4. I already tried to use new IPP provided in a comment elsewhere today, and renewed all certificates, but still gives me provision key not found.

Could you please go through steps included in this [documentation][1]? It seems like your provisions may not be set up correctly. Please also go [here][2] and make sure that your Apple Cert is up to date!


Setting Up an Unreal Engine Project for iOS | Unreal Engine 5.1 Documentation

But, if I had provision wrong, wouldn’t that give me invalid? Also I have just double checked steps, and I have done them all, also have updated Apple cert, still doesn’t work :/. I have uploaded a previous build into appstore, however it was with 4.9.2, however same no longer worked with 4.10.4.

Does your project have code in it? If so, you’ll need a Mac in order to package it, or you can set up remote build on your Windows computer, which connects to your Mac. If you do not have code in it, you should be able to package it.

Try this:

  • Open ProjectLauncher
  • Check Build
  • Check Build UAT
  • Select Cook by Book
  • Check Cook iOS
  • Select Package & Store Locally
  • Select Do Not Deploy

I don’t have code on mine. I was able to package in past, but when I try and upload in application loader it tells me that provision key is wrong.

This issue seems to have been reported previously. issue should be resolved in 4.11 however it’s best not to start working on a project in a preview build of engine.

With that being said, please [review this whole thread][1] and try suggestions provided by Pete. He is our iOS developer who has fixed this issue in later builds.

Once you’ve tried all that is suggested, please let us know whether or not this has resolved your issue. Please also try in 4.11 preview with a sample project to see if iOS works.


iTunes Connect invalid binary - Mobile - Epic Developer Community Forums

Update: I have tried now in 4.11, and I get same issue, even after issue new certificates and provisions for new build. I have pointed this to and awaiting answer now. Many thanks for help so far.

Psauer fixed issue. Many thanks!

Thanks for updating! Have a great day!

@ how you fixed issue?

I was about this issue in this thread at time: iTunes Connect invalid binary - Mobile - Epic Developer Community Forums

Pay attention that I was using 4.10 at time, and even though when compiling I was getting error saying that compile was missing prosivion key, it worked fine when I uploaded it into appstore. Hope it helps.