Download

Proven method to reduce light-map problems via Blender?

Does anyone know of a proven method/workflow to reduce light-map problems of Blender-exported meshes?

I have spend 2 days trying every different UV unwrapping combination, remodelling assets, changing the size/resolution of lightmaps inside UE4 & I still cannot nail down why this occurs.

I have followed several Youtube tutorials & read Answerhub documentation. What are your thoughts?

11ea45348db2398d74b22c46ed20ba2cc22ee1cc.jpeg

Do your walls have thickness, or are they just front faces?
What light are you using?
Do you have a LightmassImportance volume set up?

Thanks for your reply -

  • This mesh has just front faces, although similar problems occur with cube-walls.
  • Just a skylight currently
  • Yes; with the default parameters

Again - re UV-mapped the mesh, checked Answerhub & there are no common fixes that I can find to VERY strange mesh/light behaviour. How different is the 3DSmax import to UE4? Has anyone else overcome similar problems?

8ca92cbaccca05dc5268d10f4a7d24fafdd664f5.jpeg

And here with the mesh with solid walls; production quality. 3 separate meshes - ceiling, walls, floor. No overlapping UV’s, all lightmaps 2048 size.

Here again - same as previous except modified (slightly reduced) lightmass settings in World Settings as recommended elsewhere;

Reduced Lightmaps to 1024 each to save a bit of compiling time; reduced World Lightmass Settings by .5 just to see what would happen:

Doubling previously mentioned World Settings to see what would happen - yeah, don’t do that.

Ive had similar issues with importing from blender. I ended up using walls with thickness. Also if any of the walls overhang the other walls where they meet in the corners the light will bleed into them. Upping the lightmap resolution fixes that. For example here’s what ive got from blender so far.(sorry not at my computer, only pic i have)

Edit: if you can shoot me over the blender files ill take a look when i get off work and pull them in my scene to troubleshoot

I only have that sometimes when I use objects without thickness.
You could also try to make the material on the walls 2sided.
Oh and another one: Do you use “Preview” or “Production” in your light built settings?

Thanks - I’ve uploaded the .blend here: https://www.dropbox.com/s/9jcyxlggo8norm2/Lightbleed_model.blend?dl=0 Your scene looks pretty nice by the way!

  • The current mesh in the screenshots is made with an extruded cube and has thickness.
  • All materials are 2-sided.
  • The light-build setting is set to “Production”

Hi K0katu, one good solution (for me works fine) is to place all around the house black shaded poligons.
…don’t know if you have yet, but download “Xoio Berlin flat” and you’ll understand what I mean :cool:
Let us know how it goes.

Cheers, Paolo

K0katu, here is what i got, all default lighting

I imported the mesh as multiple pieces. IE i imported the interior (select in object mode in blender, export .fbx, on the left select Selected Objects, and changed the scale to 100), then the top mesh the same way. Let me know if that works on your end :slight_smile:

Thanks for the update; Synyster999 that’s exactly my workflow also. Can I ask -

  • did you alter the UVmaps at all inside Blender before you exported?
  • what specific light-quality-build and lightmap size did you use? It looks so clean!

Paolo - thanks I’ll check out the demo now.

Side noob question - is the orange feel of my images the ambient light reflecting from the surface of the floor? How can I reduce that effect?

Yea the orange color is most likely from the light bouncing off the floor. I used a post processing volume in my scene and tweaked the indirect lighting color and scene tint to fix it a little.

The only things i did was up the lightmap resolution to 1024 i believe because it is a large mesh. Bit that was because the shadows were blocky, i didnt have any issues with edge bleeding even at 64. You also had 2 uvuvmaps in blender, so i deleted the second one and let unreal generate the lightmap. Also i built at production level, preview and medium level gave me shadow artifacts but no light bleeds

Side note: did you start your level from scratch or build it from one of epics examples? I ask because at first i was using the default third person blueprint level but couldnt get my lighting where i wanted it to be. So i made a new blank level and havent had issues since

Thanks for you help - I seem to be getting somewhere with a much better result now. All I did was re-created the external blocks as per the Berlin Flat - I also made the other tweaks mentioned in this thread.

Glad to hear!