Projects settings bug "these settings are always saved in default configuration file, which is currently writable."

Hi, last time I have problem in my project with projects setting, on all options I have information “these settings are always saved in default configuration file, which is currently writable.” and I can’t save anything. Is that normal? I’m blocked something? I can’t Set as Default anything and when I close the project and save everything, I still have the same information. I’m using 4.2 engine.

Hi Necner,

Could you please provide a screenshot of what you are seeing on your end so we might better understand the specific situation? Thank you!

Same here, “Set as Default” is greyed out, can’t save anything even after I change some settings.

4.2

Hi polytopey,

Can you post a screenshot of what you are describing? Thus far I have been unable to reproduce this on my end. Thank you!

Hi Necner,

Thank you for showing me your bug. This is a known issue and is currently being assessed. The bug tends to be specific to collision channels. Unfortunately I do not have an adequate timeframe available for a fix on this. However I do know a workaround, located here:

Please try this and see if it helps you while we assess this bug.

As to the grayed out “Set as Default” and “Restore to Default” buttons in the project settings. These two buttons are actually used in Editor Preferences only. Because your project settings should get saved as you make changes and each are project specific, these buttons do not tend to be used within the project settings folder.

No screenshot needed. Just click on the import button and import the input.ini. Seems somehow the default Input.ini doesn’t get loaded (for me this is the first time it happened with the 4.4.2 release)

Other than that the 4.4.2 release is giving me error / crashes more than any other engine release/update till now

Hi KillerSneak,

Did you try the workaround posted above? Did this work for you?

Yes I had the same problems when using an active SVN for my projects. This is how I fixed it.