Projectile works, but won't steer toward the set target (homing). What am I missing?

I’ve made homing projectiles before, dunno why this one’s not working. In fact, I copy/pasted this projectile movement from another blueprint, and it works in the other one, just not this one. What gives?

I noticed my older projectile had a delay and just tried it. Did not do the trick. The projectile just flies right on by the target. Even had a print string let me know exactly what was being set as target. Just made it so the projectile shows visible line traces on a loop from it to the target to confirm, and the target is set just fine.

Turning off simulate physics worked

With what you are doing there it should only be getting the first one in the array all others would not get effected. Which means you AIcharacter only the very first one in the array can be targeted, any more after that first one spawned or placed, even destroyed and re-spawned will not be effected, this will only Target the first one in the array.