Download

Projectile movement/collision issue

I’ve been messing about with some projectiles this evening and have found that I have the choice of:

  1. Have a default scene root with other components attached. Can’t get collisions.
  2. Put static mesh in place of default scene root. Projectile movement has no effect.

What am I missing here? Obviously I’d like to spawn a projectile, it actually move as intended and then act on collisions, but I just can’t find the right set up.

As a bonus, how do I get the “default scene root” back?

Thanks in advance :slight_smile:

Root (scene component)
Capsule Collision (this is what collides in the world)
Static Mesh (this is what you see)
Projectile Movement Component ( handles the physics )

So this is what it looks like

In this state it doesn’t collide with anything (SphereCollision is set to BlockAll for now).

If I drag SphereCollision over DefaultSceneRoot, it doesn’t move on spawning.

I would recommend looking at the FPS Template Project. It has a projectile that’s setup already that you could use for the example of how to setup your projectile.

Good thinking. I did that and I noticed that my object type was set to “world static”. Weirdly, though “projectile” was an option in the FPS template project, I didn’t have such an option in my project. I’ve set it to world dynamic and it works fine now. Thanks for the help.

Here’s my current demo projectile.

projectile.jpg

Projectile Collision

You’ll need to setup two Collision Object channels in the project settings.

Set the Collision Object type of your Projectile collision component to “Projectile” and the Capsule Component of your character to “Pawn Capsule”.

This setup ignores the capsule so projectiles hit the character mesh.

1 Like

Wow thanks for such a detailed response! I’ve been fiddling around with this for a while now and my projectile just doesn’t spawn. I’ve followed everything you’ve done but it only works when I turn collision off for the projectile, putting me back to step 1.

I’ve also checked that where the projectile is spawned is set to “Always spawn, ignore collisions”.

what are your projectile movement settings?

Verify that the projectile isn’t hitting (colliding) immediately just after spawn. If you have “Destroy Actor” executed during the hit event disable it and test. Make the projectile mesh a bit bigger. Verify Speeds.