Projectile hit the player only if the player moves.

I’v already seen this post:

And followed the solution it has to offer.

I’v tried to mark the projectile and the character as BlockAll and also tried custom settings with all the collision options on.

Still the player will receive collision only when he moves.

Is there a way to fix it?

First, for me its working fine.
Second, wrong forum section.

here&p=411903&viewfull=1#post411903) the showcase project which i slowly develop each time when someone in blueprint forum section cannot handle feature by himself.

  1. It doenst matter if its working for you if he has clearly problems with that O.o
  2. He has 3 times the posts you have i think he knows?
  3. Your last sentence has nothing todo with his problem.

@: I have the same error and it has something todo with the gunoffset.

The offset is set so that the projectile is spawned infront of the player.
If you move and fire there is a small delay in wich the projectile is spawned but not activated. And there the player already hits the ball!

Have you tried to shoot at a wall so that the projectile jumps back at the player? If your projectile does that :smiley:

Thanks! It seems like the projectile didn’t collide with walls either lol.

The root component of the projectile had no collision, only it’s child has.
After setting collision to the root component, it starts colliding as it should.

  1. it does matter, because thats feedback and that’s why answerhub exist
  2. seems not
  3. yes and not, it should be demonstration how to make projectile(yes part) but i screw up with implementation and did not test(not part), so its my fault.

On character’s Capsule Component, Collision advanced tab, check to true “Use CCD”; It fixed this issue for me back when I was using UE4.6, if nothing have changed since then maybe that helps you.

There is no place for these kind of posts in the forum. Only in AnswerHub. And I usually get solutions faster here ( just like now, I was posting it on answerhub too and despite the fact that someone tried to help me, here I’v got an idea that helped me solving it ).

Thanks but I’v already solve it, see my previous replay to know how.

  1. seems not

wow you are one cocky dude.

I’m well aware of this forum, and it is good for “Blueprint-Visual-Scripting” questions ( as it says ).
And what I had here is a problem ( potentially a bug ). The right place for this post is at AnswerHub, and I’v already mentioned why I’v posted it here too.

In physical world there’s always fists… In forums there’s always the Ignore function :wink:
I would just ignore him.

that escalated quickly
quick resume: he knew the place, he knew even two of them, he knew they know about his problem and they said the solution, he chose not a right place, turns out his problem was his fault, he got pointed out by “cocky dude” about his decision to post in a wrong place(not about problem being false problem and his own fault), cocky dude got ignored.
do as you wish nate.gif

btw, bruno, could you visit this topic, once again, cocky dude would much appreciate if you can share some knowledge.

Try an “On Component Begin Overlap” on the Projectile (StaticMesh?)