Projectile goes through walls no matter what!

So I am trying to make projectiles not going through wall, I did everything I read online, used CCD, activate collision, yet… Nothing seems to work, hit event too doesnt work, physics material on wall doesn’t work… I am trying to have a collision to 2 projectile a bullet, and a brick (thrown by a boss) and they both get through walls and so on… I also put the collision box as root, but nothing works, if anyone could help me, that would be appreciated =/ also I am new in UE4

I might need more information, but it Sounds like the collision channels aren’t setup correctly. Collision Filtering - Unreal Engine
Both objects need to be set to block each others channels:

So collision lets say your projectile is on channel “PhysicsBody” and your walls are on “WorldStatic”. Then your projectile static mesh collision channel setup should block the “WorldStatic” channel and the Wall static mesh should block on the “PhysicsBody” channel.

Collision geometry can be setup in the Static Mesh Asset editor. You don’t need to add that in blueprint (this would be useful for invisible collision checks)

If you open your static mesh asset, there should be a Symbol at the top row with the name “collision”. This should mark the colsion as agreen wireframe. If unreal didn’t setup a collision by itself you can add one in the very top menu point Collision. Add Simple Collision to a Static Mesh | Unreal Engine Documentation
Performance wise it usually cost more in that order: Sphere, Capsule, Box, Convex.

Btw. CCD is usefull for very fast physical collisions, compared to its size. It basically updates the position more often than usual and has a higher chance of intersecting with other collision. If you hover over the checkbox in the engine you’ll get a tooltip for that.

Thanks for all these info but anyway I figured it out, it was my fault I set up a projectile collision but yet still was going through wall, as it turns out, I forgot to add the “projectile” collision preset on my collision sphere for my projectile, my bad lol I only added it on my static mesh, so wasn’t working, thanks either way