Projectile Collision Detection not Occurring

I am creating a basic top down shooter game where I fire projectiles out of the front of a ship. The bullets collide with the nose of the ship easily fixable and fine for now but ignore every other object. I want these projectiles to collide with walls and other actors, but they merely phase through them. I have Collision presets to custom, collision enabled, and object type set to world dynamic. It’s all on block except for visibility and trace yet it goes through every object like they were never there. I have done these exact steps in Unreal Engine 4.7.6 and had it collide with no errors but in 4.8.1 it seems to be acting differently. If anyone would have any suggestions that would be great.

I figured it out! to make your projectile, make a sphere, then say edit it’s blueprint then you can set the collision for the StaticMeshComponent (inherited). That’s the only way I’ve found for it to work.

Perhaps I’m a bit new at this but could you perhaps show me how it’s done? I’m unable to find in either the unrealscript, collision presets or any of the sub menus in there The setting you’re referring to. I’ve tried getting a newer version and putting every object and character to no collision but I’m still getting the collision with my character despite this, but no collision with any other placed Objects.

I guess I should mention that I’m using a box and a paper sprite.