Project won't package; weird Fatal Error

I was stupid enough to not test package when I moved from 4.9 to 4.10. I recently found out I can’t package it anymore in 4.10 - and I can’t trace the problem. The log just shows “Fatal Error” and nothing else =(. The minidump also shows nothing.

The first time I tried packaging it, it stopped at this line:

MainFrameActions: Packaging (Windows (32-bit)): UE4Editor-Cmd: [2015.12.11-15.52.14:458][ 0]LogOutputDevice:Error:

And then “Unreal Engine 4 has crashed” - however, clicking “close program” didn’t close it at all. It was just stuck at that line, and I could cancel the package. So basically the logging itself crashed something…
Every attempt after that didn’t have the problem, but spat out the log below.

Could anyone hopefully point out what the issue might be?

[link text][1]

70266-dndsimulator2.log (1.37 MB)

I do not see anything that is standing out within these . Do you have a capture of the crash reporter by any ? If so, could you upload it as a .txt document in your next reply?

Thank you!

Create a copy of your project if it’s not too large. Delete the Intermediate, DerivedDataCache and Saved folder. Then try to package again. Give me the full output if an error occurs. I’m hoping something will pop up, or this will resolve the issue, as sometimes it does.


Hi ,

Unfortunately there is no crash reporter since UE4 doesn’t crash. It’s the window’s “UE4 has crashed” window that pops up - which doesn’t do anything.

I have been testing extensively on copies for the past few hours, and sometimes the fail has different fatal errors.
Normally it’s the case that I mentioned earlier, where it shows nothing.
Rarely it shows:
LogPhysics:Warning: PHYSX: …..\PhysX\src\NpScene.cpp (2946) 8 : PxScene::unlockWrite() called without matching call to PxScene::lockWrite(), behaviour will be undefined.

Fatal error: [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\CoreUObject\Private\UObject\SavePackage.cpp] [Line: 139]
MainFrameActions: Packaging (Windows (32-bit)): UE4Editor-Cmd: Attempt to save bogus object 000000002CB26080 ThreadContext.SerializedObject=None SerializedProperty=ObjectProperty /Script/Engine.MaterialInstance:Parent

However attemping to those two specific problems, it seems to do nothing with my project.

This might be important to mention, but there was once it just randomly built successfully. I tried reproducing this but further attempts failed again. This seems like a very bizzare problem!

Seems to be bad news that there’s still no error =( Same problem persists

Interestingly the last output shows LogOutputDevice:Error:
And that’s when it dies.

[link text][1]

70300-testing.log (940 KB)

Interesting update:
I removed all the actor blueprints that were a child of one main parent blueprint. Those were the ones that were giving:
LogLinker:Warning: CreateExport: Failed to load Parent for Function /Game/Blueprints/Tokens/EnvObjects/Token_GrassPatch.Token_GrassPatch_C:UserConstructionScript; removing parent information, but keeping function

Which is weird, because that shouldn’t cause this kind of problem.

Once I did that, I also deleted Intermediate and Saved folder, and I was able to package them - once. Packaging it any time after that caused the exact same problem from before. This is replicatable.
(However the very first time I managed to luckily package was under different conditions, unrelated to the child actor blueprints. Weird!)

Do you have full reproduction steps that I can follow and reproduce here to enter a bug into with? When it’s an incident that only happens on one project but not the others, it typically falls into how it was set up. But if you could provide me with reproduction steps that would be extremely useful.

You may want to try recreating those blueprints that are throwing warnings in the output as well. Sometimes when the editor updates to a newer version and the project along with it, the changes in code from the newer version will cause issues with the older code from which the project was originally created.

Looking forward to hearing back from you, thank you!

Hi ,

Sorry for the late reply, just finished my finals! Unfortunately after about 20 hours of tinkering I’m afraid it is an issue deep inside the engine from upgrading versions (4.7 → 4.9 → 4.10) using the same project, and I am unable to figure it out.
I have decided to migrate my maps into a new empty project. This has been a two year solo project for me so it’s quite large - the migrate function works partially for such a large project, but at least it can successfully build now. I will be spending the rest of my time getting the rest migrated and work properly.

Thank you for the replies and support =)!

You’re very welcome.

In the future, make sure you creating COPIES of your project instead of converting them to the new version of the engine. This way, it’ll be safe. Those who are actively working on their project and they’re planning to release it as a game, they do not upgrade their project unless they’re using the source version of the engine, and are able to add in features they need to their version of the editor.

Good luck! :slight_smile:

I actually tried cloning them - but for some reason it wouldn’t clone half of the assets I had. (So I had to resort to migrate - but it works!). It might be some deep mistake I did for one of my assets that’s causing all these problems…but there’s too much to check one by one now haha.

I agree with you, the only reason I upgrade my project is because of the UMG bug fixes w/ VR which is the basis of my game. I’m going to be learning C++ with UE4 so I’m able to work using the source version, plus lots of benefit in mixing both C++ and BP’s!