Project wont open after restart


i know there are several posts about this from before, however none provided answer in any good fashion about this problem.

We have a pure blueprint project started from an empty template.

50% of the time when working with the blueprints ex making big changes in blueprint like structs, adding new functions, rewiring etc messes up the project somehow. So, when restarting the editor the project wont load and crashes the editor at “93 or 96%”.

It then takes hours to move things out from the project folder, trying to find any culprit, trial and error. Eventually it gives in and can open.

Is there a way to avoid these things or even better, a better error report upon editor crash, that you can understand what goes wrong beforehand, or catch it upon exiting etc…

thanks for any answer, its extremely annoying and a real showstopper.
Its like you wirte a piece of code and the next time you open visual studio each and every letter is gone.


looking at the log i have alot of these similar issues

LogProperty:Error: UStructProperty::Serialize Loading: Property ‘StructProperty /Game/blueprints/game/dd_savegame.dd_savegame_C:gamecfg’. Unknown structure.
[2015.03.14-07.36.12:214][ 0]LogProperty:Error: UStructProperty::Serialize Loading: Property 'StructProperty

I wonder why the struct cant be loaded?


after some hour moving files out from the folder, restarting etc its solved…
I would however want to know how to avoid these things in the fuiture because its quite time/energy consuming and very dangerous for the project / Highrisk if sometime it cant be fixed by hacking anymore.

Hello Molin,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. What version of the engine are you using?
  2. Could you elaborate on what issue(s) you are having exactly?
  3. Can you reproduce the issue(s) in a clean project?
  4. If so could you provide a detailed list of steps to reproduce the issue(s) on our end?
  5. Is this a project that has been updated from older versions of the engine?

Hi Rudy

thanks for answering

1 - 4.7.2

2 - Well the issue is… Often after extensive work with blueprints the project wont load after editor restart. I then have to move blueprints around on the disk until it opens, try to recompile some variables referencing structs, move files back and then hope for the best and keep doing that until its solved.

3 - Im not sure havent tried

5 - Yes, since 4.4ish

again today trying to open the project just started crashing again at the same thing, this is bonkers…:confused:

LogProperty:Error: UStructProperty::Serialize Loading: Property ‘StructProperty /Game/blueprints/game/dd_savegame.dd_savegame_C:gamecfg’. Unknown structure.

Its hard to create a repocase since i dont really know where to start im afraid.

is it possible for you to have the crashdump or even the whole project?

Hello Molin,

Can you try and reproduce this issue in a clean project and then provide your findings and/or the steps to reproduce this issue on our end?


thanks for your time i really hope you find something, it will crash instantly on start so you wont have to look far.

Please disregard the heavy prototype state of the build

I will remove the download link when you have retrieved the file

also worht mentioning, move the map files to get the editor to open at all.

Hello Molin,

I would be more than happy to take a look at your project if you would like to provide it. You can zip in down and send it to me in your next post. This can be down with google drive or dropbox. I hope this helps.

Hello Molin,

I have narrowed it down to your gamestate. “dd_gamestate”, and I believe that you will need to replace this blueprint. You can simply delete the blueprint before opening the project and this will keep the project from crashing. If you would like to be able to view the blueprint so that it will be easier to rebuild, you can copy and past it into a clean project’s content folder. The references will be broken but you will still be able to see the logic. This way it’s a simple matter of rebuilding that one blueprint. From what I could gather, this blueprint had a broken/bad reference in it. I hope this helps.

Make it a great day

yes ill rebuild that and se where it gets me.
thanks for your valueable time and for looking at it, it did indeed start more consistent without it. State and Mode blueprints are problaby the oldest ones.

im also considering starting the project from scratch wich probably will get me more stable blueprints since they are a mix from previous versions converted up to 4.7.2.