Project won't load

This happened to me twice already.
Thankfully this time, I have the logs before project got corrupt, so re-posting as bug.

OK, so this is what happened this time:
I was writing code in VStudio, then rebuilt the project. Result was successful

Then I went back to the project and noticed the Compile button gone, so closed it to re-open.
Then on the re-open, 71% crash again.

The logs show that after corruption, project fails to load on the source control stage. I’m not using source control FYI. Help…

Log file before corruption:
link text
After corruption:link text

Hello Dirt113,

I have a few questions for you about your issue.

  1. What operating system are you using?
  2. You have your version listed as 4.8, can I assume that you are using the 4.8.3 hotfix?
  3. Have you attempted reverting the code changes that you made previous to this problem?
  4. To fix the problem temporarily, can you try deleting your Binaries, Saved, and Intermediates folders and then Generate Visual Studio Project files? If you compile after this, you may be able to launch.
  5. Have you tried later versions of the engine? We knew of multiple issues in 4.8 with Hot Reload that may be causing this which were fixed in 4.9.
  1. Windows 10 release
  2. yep, 4.8.3
  3. I found a code error and fixed it, now the editor at least runs. But it crashes on compile of anything : Garbage collector error causing crash on compile of ANYTHING - C++ - Unreal Engine Forums
  4. I tried that several times before the fix, with no success
  5. No, but I can’t since I’m using content packs that don’t support 4.9. I’ll try this now.

Hello Dirt113,

We haven’t heard from you in a while. Have you had any chance to try 4.9 yet? If so, was it able to fix your issue? Please comment to let me know. In the meantime, I’ll be marking this issue as resolved for tracking purposes.