Project won't load with player controller in project

I have two problems that seem to be connected:

  1. I can’t reference my player controller blueprint anywhere until I open it first.
  2. Once I do open it and reference it somewhere, the project no longer opens once closed. It gets stuck at 72% every time with this final log output message:

LogUObjectGlobals: Created PersistentFrame Addr=0x00000295693d4100, Size=64, Default__PlayerController_Raindrop_C Function /Game/MyContent/Blueprints/PlayerController_Raindrop.PlayerController_Raindrop_C:ExecuteUbergraph_PlayerController_Raindrop

I tried removing the player controller .uasset file from the project, and it loads. However, everything in my game depends on it. I’ve tried creating brand new player controllers and referencing them, which causes the same exact issue.

I can now no longer develop my game any further until I get this fixed, and since I’ve been working on it for the last year, restarting is no longer an option. The only similar problem I found through my research is from this post:…er-crashe.html

However, it’s worth noting that my editor doesn’t crash, it just won’t load up the next time I open the project after placing a reference to the player controller somewhere.