Project will not open or fully crash

While I was editing a color on a UI element I hit undo without thinking it might be a bit wonky to do so while the color picker was still open. The editor crashed out, and silly me not thinking tried rebuilding everything and didn’t think to save the crash log from that initial crash. I have since been unable to open the project. It gets up to 75% and then sits there with 0% CPU and 0% disk usage. I’ve now been running it for over 2 hours in VS debugging, it says it has exited 27 threads with code 0, each popping out about every 10-15 minutes, but has made no progress towards actually opening. The project is a C++ project, but it compiles just fine and it was running without issue for several hours since my last source code adjustment so I don’t believe my source code is the issue. I have attempted:

  1. Delete the .vs, Binaries, Intermediate, and Saved folders as well as the .sln file, and do a full rebuild from source.
  2. Verify my Unreal installation (at first the engine wouldn’t open at all)
  3. Uninstall this version of Unreal and reinstall it. (no change)
  4. Uninstall all versions of Unreal and reinstall this one (engine now opens)
  5. Full rebuild from source again and… Nothing. Just sits there for 2 hours now slowly collecting more and more RAM not crashing or using any resources besides memory…

I’m running an 19-9900K, GeForce RTX 2070 SUPER, 32GB of RAM. Unreal 4.25.3. I typically open the project in around 15 seconds so very confused how it’s not crashing and not done doing something while somehow without using my CPU or disk.

Anyone seen anything like this or have any idea what could be happening here? I appreciate any help you can spare!

Output Log

After many hours I discovered the issue. Well, I fixed it anyhow. I created a new project and then copied the source and content folders in chunks, eventually narrowed it down to a file I created weeks ago and has not been an issue until suddenly today. It’s a blueprint implementation of a PrimaryDataAsset I declared in C++. I removed the .uasset from the content folder and i the project opened back up. I then created the file again in editor, and it crashed on PIE. I then removed the file again, got back in, and recreated it with a different name. Now all is well. The file was named HID_Tank, renaming it to TankItemDefinition fixed the issue, so not sure if it’s a naming convention issue possibly? I’ve never seen anything like this in my 6 years working with the engine, it always does at least something.

You should mark this one as solved, glad u got it tho m8 :)))

I let it sit for the day just to see if it came up again, and it did. This morning I’m back to the same problem :frowning: I can remove the file before launching the project and restore it, but I’m going to need to make a ton of these so that’s really impractical long term, and not sure what’s going to happen on a cooked build.

Restarted my computer and had the same issue come up today. I can delete the file, open the project, restore it from the recycle bin, reattach all references in project and it works just fine, but I cannot just open the project with the file in there.