Project unavailable after updating to 4.7.5

After the automatic update, I tried opening my project (that had previously worked with 4.7.1). The project got stuck on “downloading assets” and the project was black in the editor–no assets showed up. What is going on?

Also it insists on opening in version 4.3.1. 4.7 does not show up in the lower right corner–it says “Other”, and I am unable to open it in 4.7.

Try opening the editor first and then go to File>Open Project>Your Project. Does it open if you do it that way instead of trying to open from the library?

Works! Thanks!

The same thing’s happening to me, only that trick isn’t working.

After updating to 4.7.6, not only will Unreal not recognize any of my old projects, it also won’t even recognize projects made even in 4.7.6. All the files are greyed out, with either a “4.7” or a “?” in the corner.

Not only that, any changes I make to the copy of a project are never properly saved. I should emphasize that everything was working fine before the .6 update.

Are you on PC or Mac? Additionally, If you create a new, blank project with no additional content, are you able to save? Can you open your project file by going to the project directory and opening the .uproject file there?

I’m on a PC running Windows 8.

Curiously, before I could even try to make the test project, I noticed that it’s properly recognizing files now. Saving also seems to work properly. I didn’t change any of the core settings before or after, so maybe my computer just needed to restart. For now, at least, it looks like the problem sorted itself out. Thanks for the reply, though.

UPDATE: Nevermind, “the engine not recognizing old files” is back again. Thankfully, while newly saved data is never reflected if I just make a copy in Unreal’s Project Browser, if I do what you said and open the .uproject file separately, it works just fine.

Try right clicking the .uproject file and setting the “switch engine version” to your 4.7.6 version. Do you still get the error after this?

Because the issue seemed to come at random intervals, I’ll keep posting if it breaks again in the future. For the time being, however, doing that fixed it completely. Even if I close and restart the browser several times in a row, it now retains which engine it should launch in.

Excellent! I will remark this as answered for tracking purposes. If you experience the error again, please feel free to comment and I’ll take another look.