Project stops at 96% after conversion

I am trying to convert my project from version 4.22 to 4.25, I fixed many problems but now it just stops at 96% of the loading, here are my logs for the project.


I don’t see any weird errors or something like that it just stops loading, if anyone knows more about these please do share, thanks in advance.

Hi there DDemon, you already tried to remove the “Saved” folder and the “Derivated Data Cache” from the game?
if you’re worried, please make a copy of everything and try open the game after removing these 2 folders, the engine wil recreate them and it can take some time.
See if this works

Hi, thanks for the advice I have just tried it and sadly it didn’t help, I have verified the engine files as well but it’s all the same.

Oh i see, you have Visual Studio Installed? If you do, you can try to delete the “Intermediate” folder from your game, and then right click on your game’s icon and select “Generate Visual Studio project files”

Just tried that it only generated some file in the logs but still the same result in the loading stage…

Sorry to hear that :confused:
How much time you let it loading? My game for example is a little big so it took some time to load for the first time

Yeah it’s really strange, i will do some research

I waited for an hour, I had many projects and never the wait time has gone over a few mins and again it works fine on version 4.22 but something breaks on 4.25.

Thanks, I will do too.


I checked Log file and I saw this;

[2020.10.30-16.15.36:588][ 0]LogWindows: Failed to load ‘OVRPlugin.dll’ (GetLastError=126)
[2020.10.30-16.15.36:588][ 0]LogWindows: File ‘OVRPlugin.dll’ does not exist

If OpenVR or another AR/VR plugins enabled in 4.22, try to disabled them and retry to convert to 4.25.
It may work.

This error came from Oculus plugin that was enabled from the start sadly removing it does nothing just removing the three lines of the error from the log. I have tried to convert my project on another machine as well but it got stuck at the same place, so it’s not a hardware issue.

After trying many many things from generating new files to opening 20 new projects with small changes every time, even leaving the loading for the night, even converting to 4.23 first(with worked fine on this version) and then to 4.25. I at last found the problem after comparing logs of a successful build of a template project to this one. The logs here stops before loading the levels so I guessed that the problem was there, so I deleted the levels and walla the project jumped through the 96% and opened as normal. (I did try to delete most of the actors on the level but it didn’t help so I just started from scratch).

Never mind all of the project is corrupted, what happened is when the map tried to load even one of my blueprints it went into an endless loading now when I try just to open one of them the same thing happens it just continues to open it forever no errors, nothing and worse I can’t even create a new blueprint because it crushes the editor.

I’m sorry to hear that, the older version still works right? You already tried open it, right click on the content folder and select “fix up redirectors in folder” and after that “validade assets in folder”?
This may take a while and i suggest you let your computer only doing that, but it can show you the exact blueprints and maps who are corrupted and maybe fix some things.

Found the problem it was corrupted structures sadly it took me two days of work to find the problem and only 30 mins to fix it, as I understood most of them were structures that used Dictonerys so if someone has similar problems and using a lot of structures you should check them out.

I’m glad you found the problem :slight_smile: