Download

Project stopped receiving keyboard input with no changes.

Hi folks. I don’t tend to post much - generally I’m able to figure out my problems just from lurking - but I’m really stuck with what I hope is a really minor issue that I cant figure out. I’m hoping that I’m just missing something simple: still being relatively new to UE4.

I have a number of keyboard input commands that I am using to test pieces of my project as I progress: however these have all stopped working out of the blue.

Put simply, they worked. I had my project in a state where I would press the command, the blueprint seemed to be working correctly, it caused an update to the HUD and a printstring triggered to inform me it had finished. I tested it a few times to ensure there were no issues when all of a sudden, my keyboard inputs stopped working.

Not just in that instance either: restarting the test did not help: I still had no input.

I added two printstrings to the code: one immediately on begin play (to ensure the game was working) and one immediately after the keyboard input. The first worked, but the second did not - telling me that the game is running and the character is spawning but for some reason isn’t receiving my input.

I found that running the test in a new window bypassed the problem - irritating but workable - but when i returned to the project this morning even that doesn’t seem to be working. This means that I cant test my game short of exporting it (which I haven’t tried yet to be honest) and am… kind of stuck.

Capture3.JPG

Apologies if this is posted in the wrong area: I didn’t see a better place at a glance and my project is build entirely with blueprints.