Project parts lost

So, I was using UE 4.8.1 with my partner, we were using Git as our Source Control, we had a problem here and there, but it was fine, it was our fault for doing weird stuff.

However, today something REALLY weird happen. I made a commit(through UE4 source control) and sync(using github client app) and all was well and fine, until my partner pulled all the stuff I had been doing. He said a few things (that I had supposedly done) weren’t working, which was weird, I came back to my computer to check and it was just fine, but when I synced with his commits, everything was gone, stuff that I had already deleted(before he had done any sort of commit or push) were back and all my work was gone.

I checked the committed files of each commit and things seemed to be quite right, so I don’t suppose it was a git thing. I also tried to rollback to my initial “everything working” commit, but that didn’t help.

We previously had ran into some trouble with renaming folders (we renamed the main folder inside the content folder and after we commited,pushed,etc it was back alongside the new named folder (?)), which was fine nothing game breaking.

But now I just lost everything I had been working in the past few days.

I done everything that is in the ue4 tutorial as how to connect to git and stuff and still had all lost, I mean, ok in theory source control with git is still in Beta, but still…

And FYI there is no error or anything, things just disappeared, literally.

I’m using a mac(was unreal actually meant to work with mac? Because I keep running into problems here, whereas my partner mostly doesn’t, aside from a few random crashes(!)) and my partner is using windows 8.

We’re really considering going back to Unity, but I’d really like to know if I possibly done something wrong.


Did you checked git history which commits was ok? you can always checkout older commits and retrieve files that you can, you can revert whole repository

Ops, I forgot to mention that I tried to rollback to a previous commit. But the work still wasn’t there =/
I’ll be editing the original question.