Project loading always crashes at 52%

The crash window has a link to a folder where the crash log files are saved. Could you share any additional insights from them?

If you start with a brand new project, does it still crash or is it just the project you are working on?

My problem seems to be my project, which is corrupted or something like that.

I tried to remove the Intermediate, Build, Binaries and Saved folders… regenerate my project files, recompile, but nothing is solving my problem.
I also tried to install the debugging symbols and it says : Error alocating bytes with alignment 0.

It has been 3 days now that i’m stuck on this and I’d like to know if someone could help me.


Ok, so here is what I got in my latest log file :

[2018.01.16-15.39.32:995][ 0]LogThreadingWindows: Error: Runnable thread FAssetDataGatherer crashed.
[2018.01.16-15.39.32:995][ 0]LogWindows: Error: === Critical error: ===
[2018.01.16-15.39.32:995][ 0]LogWindows: Error:
[2018.01.16-15.39.32:995][ 0]LogWindows: Error: Fatal error: [File:D:\Build++UE4+Release-4.18+Compile\Sync\Engine\Source\Runtime\Core\Private\GenericPlatform\GenericPlatformMemory.cpp] [Line: 183]
[2018.01.16-15.39.32:995][ 0]LogWindows: Error: Ran out of memory allocating 23714955484 bytes with alignment 0


[2018.01.16-15.39.32:996][ 0]LogWindows: Error: Crash in runnable thread FAssetDataGatherer
[2018.01.16-15.39.33:018][ 0]LogExit: Executing StaticShutdownAfterError
[2018.01.16-15.39.33:018][ 0]LogWindows: FPlatformMisc::RequestExit(1)
[2018.01.16-15.39.33:018][ 0]Log file closed, 01/16/18 16:39:33

And this error only appears on this project only

Looks very much like a corrupted asset in your project. I assume the log files doesn’t tell you which one causes the issue, so you need to find out by yourself.
Make a BACKUP copy of it as very first thing, then delete one asset folder from the project. Try to open the project. If it doesn’t open, restore it from the backup copy. Delete the next folder and repeat until you find out the one containing the faulty asset because, at that point, the project will actually launch.
Once you found the folder, restore your project from the BACKUP copy once again, and start deleting asset files inside it. Restore and delete the next until you identify the offending one.
Hopefully there is only one of them. You will very likely need to recreate that asset but at least you can still open the rest of your project

That’s unfortunate, I hope you can easily recreate them or migrate them from another project.

Perfect (not really). I’ve scanned all the assets and 3 of them were breaking the game (CharacterBP, GamemodeBP, PlayerControllerBP)

now my project loads without errors or warnings

You are welcome. If you don’t mind, could you accept my answer above so others can find it for future similar issues? Thanks!

It’s not that bad. Actually, it’s equivalent to a full scan of the blueprint class. And so, reorganize everything. Anyway, thanks again!