Project Launcher not signing APK


I’ve been struggling with this problem for some time now. I’ve been trying to lower APK file size using -compressed -pak commands in cooker commandline. It is exposed in Project Launcher, which is why I used this method. My APK builded from standard packaging method File>Package Project>Android>Android_ETC1 is properly recognized by google play but it’s size is too big (64mb). Now, using -compressed -pak allows me to shrink file down to 40MB which is under 50 mb required by Google Play. Unfortunately file is set as debuggable, and even signing it manually after packaging (using jarsigner) doesn’t solve issue. Build and cooker are set to shipping. I’m attaching screenshot from my Project Launcher and log.


Hi Turbo Marian,

Thanks again for bringing this to the AnswerHub, and most especially for attaching the logs. :smiley: I’m going to see if we can get more eyes on your issue. In the meantime, when you tried manually signing your apk using jarsigner, did you get any sort of error? Something like “invalid entry compressed size”? If you did, please have a look at this thread, which may help. If you didn’t, no worries, we’re still working on it.

Thanks very much!

At first I did have problems with invalid entry size but deleting META-INF folder from compiled package solved this issue. I’m using this method to resign package. Will try now with lower java version.

Searching through log I have found some interesting data

ProjectParams.ValidateAndLog: Distribution=False


ProjectParams.ValidateAndLog: SignedPak=False
ProjectParams.ValidateAndLog: SignPak=

Does it mean Project Launcher reads these values from somwhere else than AndroidManifest.xml? Also I’m on 4.7.2, but this particular problem persists from 4.4.

Hi Turbo Marian,

Unfortunately, we currently don’t have a way to specify a game is meant for distribution via the Project Launcher. However, you can do this from a command line with the following command (tailored from your log):

“C:\Program Files\Epic Games\4.7\Engine\Build\Batchfiles\RunUAT.bat” BuildCookRun -project=“C:/Users/Tomato/Documents/Unreal Projects/Vitalick4.6 4.7/Vitalick.uproject” -noP4 -clientconfig=Shipping -serverconfig=Shipping -rocket -platform=Android_ETC1 -targetplatform=Android -cookflavor=ETC1 -build -cook -map=Basic_Level+Minimal_Default -compressed -pak -pak -iterativecooking -stage -package -cmdline=" -Messaging" -addcmdline="-SessionId=3AFB3BE641109EE43B6A2EA6567B2977 -SessionOwner=Tomato -SessionName=‘New Profile 0’" -NoCompile -distribution

That will do everything you specified in the custom profile as well as build it for distribution.


Solved! I also backed up to 4.6.1 engine version and my package weight 31.5 mb :). I’ll stick with it for now, and wait for 4.8. TY for help!

Where I can’t find this ProjectLauncher settings? or how I can set the “-compressed” comand?

hi piXelicidio,

Please see the answer below, it’s part of the command line settings.

APK is for Android devices. In order to run in your Browser you need to export as HTML5, that’s a different target.

How i generate a file to upload in web browser with this method? I tried, but just opened the web browser to test it.
I don´t get it.

I´ve configured the package way to build. But when i hit the “Launcher” button in ProjectLauncher window, looks like my configuration i made don´t work. Can you explain how does it work and how i do to launch properly, creating an APK file.

I had the same problem. Added “-distribution” to Additional Cooker Options in Project Launcher

Yep! Tested and working! Thanks!