Project Launcher fails but packaging itself works

I’m using a source build 4.12.5.

I attached the ProjectLauncher log.

“Program.Main: ERROR: AutomationTool terminated with exception: AutomationTool.AutomationException: Project ‘C:/Game Engines/UnrealEngine/’ does not exist”

This is the error I get in the “Launching UAT” section when I try to launch my profile.

It says the directory of the engine I built “does not exist” yet the error call stack is displaying from within the directory it says does not exist…

I can package the project fine manually with no trouble, so I’m confused.

ProjectLauncher.log

I feel a bit silly, my Project Launcher custom profile wasn’t set to my game project, it must have not saved when I used version control or closed my project or something like that, because the launcher profile worked before so I obviously did have it set to my game project before.

I just had to point to my game project.

If people are wondering, it’s at the very top “Which project would you like to use?” and a dropdown menu where you find your game project’s .uproject file.

1 Like

I just had the same problem. Build stuff yesterday, left the computer on over night. Came back, had a crash while playtesting, continued working. Wanted to build and had this problem (pointing to “UE_4”). Solved it the same way.

Actually it broke my complete custom profile and reset every setting.