Project keeps crashing at startup

I was working on using a simple blueprint interface to use between a character blueprint and an animation blueprint. I wanted to modify the interface and add an output (it had no inputs or outputs before that). It worked the first time I did it, then suddenly everything froze, a couple of seconds later UE4 crashed and closed. The problem was when i was loading it again it doesnt open, it freezes at 93% and then crashes again.

I tried removing my maps from the DefaultEngine.ini file and it worked, but when i tried to open the either the character blueprint or the animation blueprint it didnt work, actually just doing a single click on them crashes UE4 again.

Does anyone know if i can restore these files somehow ?

Hi Ahmed.Agamy,

Try removing the blueprint interface uasset from your contents folder and then try to open the character blueprint or the animation blueprint. Additionally, can you post your crash logs and callstack here so I can take a look at what may have occurred?

Hi Ahmed.Agamy,

We have not heard from you in several days. I am marking this thread as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.