Project has become corrupted, now crashes on Launch to Android

I have a project which has been working fine for some time, and after making non-functional changes to the code I was surprised to see that the application was now crashing when I use the Launch button to deploy the application, with the following appearing in the Android Log:

D/UE4     (24522): [2016.01.12-05.03.11:997][  0]LogInit: Object subsystem initialized
D/UE4     (24522): Assertion failed: PImplData->eglSurface != EGL_NO_SURFACE [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\OpenGLDrv\Private\Android\AndroidEGL.cpp] [Line: 233] 
D/UE4     (24522): eglCreateWindowSurface error : 0x3003
D/UE4     (24522): [2016.01.12-05.03.11:997][  0]Assertion failed: Assertion failed: PImplData->eglSurface != EGL_NO_SURFACE [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\OpenGLDrv\Private\Android\AndroidEGL.cpp] [Line: 233] 
D/UE4     (24522): eglCreateWindowSurface error : 0x3000
I/AndroidRuntime(24522): VM exiting with result code 0, cleanup skipped.
I/ActivityManager(  893): Process com.MyCompany.MyProject (pid 24522) has died.

I’ve tested this repeatedly, and when using the Launch button, the above crash occurs. I’ve also tried stripping out the Saved, Binaries and Intermediate folders, generating new VS project files and rebuilding- same result. The bug does not appear in this folder when using the full packaging pipeline- only when using the ‘Launch’ button.

The strangest thing is that I can get that same project to work by copying and pasting the entire project directory elsewhere on my computer- no other changes are made to the code at all, I regenerate VS files and recompile the project as with above, except this time the application works perfectly!

If this behavior changes even when the project is copied wholesale into another folder, could this be an issue with the DerivedDataCache of the engine itself?

Would really appreciate any theories as to what’s going on in this puzzling situation. Thanks!

Hey ,

Could you please provide me with the full error so I can fully see what’s happening?


Hey Samanta!

I’m afraid uploading the full error might be a bit tricky due to our NDA, but I’ve attached a sanitized snippet here- is this enough to work with? [Error ][1]

Happy to share with Epic however I’m not sure I can put the full contents in the public domain.

74592-sanitizederrorlogs.txt (7.76 KB)

While looking over your , I noticed an assertion failure.

D/UE4     (29893): [2016.01.11-10.48.26:626][  0]Assertion failed: Assertion failed: PImplData->eglSurface != EGL_NO_SURFACE [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.10\Engine\Source\Runtime\OpenGLDrv\Private\Android\AndroidEGL.cpp] [Line: 233] 

I found a couple of AnswerHub posts that had resolutions on what fixed their issue, I am wondering if it’ll have the same effect on yours.

  • [AnswerHub Post - Removing Ad Mob][1]
  • [AnswerHub Post - Disabling Play Support][2]

Could you please verify that this issue isn’t happening on any newly created project? Test another device too if you’re able to.

Android Crash On Startup - Mobile - Epic Developer Community Forums
[2]: Game crash with launch on mobile - Mobile - Epic Developer Community Forums

Hey ,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you!