Project gets corrupted after moving from 4.61 to 4.7. Causes editor to cash on exiting

crash happens on exiting or closing 100% of time with my project. Also, when launching my game through USB to iPhone5 it says Launch Fail but if I click icon game will have been updated. It never happens when creating a new project. I reproduced bug on my Windows 7 machine as well as on my Mac Pro. I have tried migrating my content into a new scene but that did not work. I tried renaming all my folders and manually fixing all broken links but nothing helps. This is a Blueprint, based game. I am desperate to fix this so I can update my game so I can move on to next game but this bug has me stalled.

Hi ,

Do you get a Crash Reporter dialogue when this crash occurs? If so, please copy information and paste it in a reply here, and make sure you submit report. Please also and attach log from your project after this crash occurs. This can be found in your project folder under \Saved\Logs. Thanks!

link text

Thanks, but we need crash log from project. This appears to be CrashReportClient log.

Thank you , I was not able to paste crash log directly. I think it was to big. Hopefully, zipped log attached above will work and is correct file.

link text

Strange, my project does not have the “Saved\Logs” folder or any log files.
I copied and pasted crash report into a text file

Ah, I’m sorry, didn’t realize this was on Mac. In OSX, you can find logs in Library:

~/Library/Logs/Unreal Engine/ProjectName

(Note that /Users/yourusername/Library is invisible. Hold alt-key and from finder menu select Go->Library)

It looks like this is a known bug (UE-13804), and any additional information we can add to report will aid in getting it fixed as soon as possible. Thanks!

link text

Thanks! This definitely looks like same bug to me. developer looking into it requested a repro project. Would you be able to upload this project somewhere and get us a download link? You can send it to me privately over forums if you’d prefer:

If you could upload Windows version of project, that would probably be easier for us.

PM sent with download

Hey ,

Thanks for letting me take a look at project! I can confirm that this is same crash we had reported as UE-13804, and updated bug to include your project information. I also emailed developer looking into it so he can take a look if necessary, but it appears bug is already fixed internally as I don’t get crash after closing editor in our main internal build.

next release will be 4.8, and project shouldn’t crash editor in that version. I believe we’ll be doing a Preview release for it soon, so you can test it there. If you need to finish up now, you can try building latest Promoted branch from GitHub.

I wasn’t able to reproduce build failure on iPhone, though. I only tried through Windows, though. If you’re still having that problem on Mac in 4.7.6, try on PC and see if same problem occurs.