Project doesn't 'see' files in content folder?

Tried migrating a texture from another project into my current one and it didn’t work. It showed up in the file explorer though. Then I exported the texture to the current project. Current project won’t find it. Then I exported the texture to desktop and moved it into my current project and still nothing imports. Got a bunch of folders and files in my content folder that my project doesn’t acknowledge in engine. Worried about adding anything to the project now.

Usual reason for files appearing in explorer but not content browser, if when you try to put assets back into a previous version of the engine. Is that what you have going on?

Are you using the engine’s built-in “migrate” function?

I realize this is old question but I just had same problem and wanted to report my solution:

right click and go to the problem folder in explorer. Select all items, cut, then paste back into same folder. Back in unreal this forces them to reimport. Worked for me.

The problem was caused by exporting items from DCC directly to Unreal content folders, and I think some redirectors got confused because I had changed material assignments, etc.

1 Like

Hi future people - I had this problem.
I stupidly copied and pasted from online resources which had the folder with assets in named “Wall Halogen”. Unreal wont load this because of the Space. I renamed to WallHalogen and instantly popped into the content browser (UE5.0.3). Hope this helps.

3 Likes

One Million thanks to you !!

Sure does work. Though when you have SOME folders with subfolders and nothing shows up it`s a hell.
Thanks for the tip.