Project doesn't compile

So I’ve been working on UE version 4.8.1 without any issues. When I wanted to implement HairWorks from Nvidia, my UE doesn’t load my project. Instead, it keeps giving me a message stating: "The following modules are missing or built with a different engine version:


Would you like to rebuild them now?"

When I choose to do so, it will keep up giving me a message that is couldn’t build the modules. So I tried rebuilding from the source but still gives me an error. Other sample and testing projects do seem to startup and function well.

Any solutions?

Hey -

I would need more information on how you are implementing HairWorks specifically, however you may need to update the projects files so it will recognize HairWorks. To do this you can right click on the .uproject file of the project and select Generate Visual Studio project files. If there is already code in the project doing this will regenerate the files along with any updated files that have been added to the project.


Hello ,

I basicaly downloaded the HairWorks files from Github, and I ran the Setup batchfile.

As your suggested method, I keep getting an error as UnrealBuildTool is having an error on building the source files.

error CS0101: The namespace ‘’ already contains a definition for 'ProjectNameTarget

Within the file:

MyProjecTName.Target.cs(6,14) (in the projects Source folder)

Any suggestions?

It sounds as though it is trying to create a file that already exists. You should be able to remove the file (move to another location or delete) from the project folder and then run Generate Visual Studio project files successfully.

I got it running again.

So what I did was that I removed the [projectname].target.cs file within the Source folder, I also updated the engine from 4.8.1 to 4.8.2 and rebuild the whole project from source. So I can access my project.

But I’m still unable to find HairWorks within UE4, am I missing something like did I install HairWorks wrong?

If you’re using HairWorks as a plugin then you’ll want to make sure it’s inside the Plugins folder of the project. When you load into the editor you can then go to Window->Plugin. You should be able to enable it from the list of plugins and then restart the project to have access to it. If you’re still having problems getting it to run after that your best bet would be to create a new post for that specifically so that the information regarding HairWorks doesn’t get lost in the depths of this post.