Project does not support whole scene point light shadows

In the RoboRecall uproject file all checkboxes under Project Settings > Rendering > Shader Permutation Reduction are unchecked.
This results in all the pointlights in the project to generate an error stating “Project does not support whole scene point light shadows” (followed by the identifier of the pointlight).

As I’m pretty much looking at the RoboRecall project files with eyes wide open (since I’m assuming this is probably the file that has the most optimal settings) are we supposed to uncheck all these boxes in our own project and ignore the errors generated by the point lights ?


For point lights you either need to turn off shadows or set the light to static. If you set it to static you’ll need to rebuild lighting for the error message to go away.

(Note that rebuilding lighting on HUB takes hours on my i2700k 16gb machine at the production quality level with the included settings.)

Hi! Just turn on this option