Project crashes on mac editor on load. Moved project from PC to Mac

Hi,

I’ve been trying to open a project brought over from UE4 on PC. Currently, the project crashes on launch of the editor every time with the ‘Building Mesh Distance Fields’ dialogue present. I’m running UE4 4.5.0.

I’ve recompiled the project through xCode with the UE4CmdLineRun scheme. The project itself doesn’t have the ‘ProjectNameEditor’ scheme or the ‘ProjectName’ scheme present in the demo projects (currently looking at the shooter game project).

Also I’ve tried deleting the ‘DerivedDataCache’ & ‘Project Preferences’ folders. And I’ve ensured that the dedicated graphics card is running by using https://gfx.io. The unreal engine is also the only program running on the computer and no external display is attached.

My system specs are as follows:

  • OSX 10.10 Yosemite
  • MacBook Pro (Retina, Mid 2012)
  • 2.6 GHz Intel Core i7
  • 16 GB 1600 MHz DDR3
  • NVIDIA GeForce GT 650M 1024 MB

Here’s all the crash logs:

Any help would be appreciated. I’m going to try another re-install for the minute. I’ll update the question with any relevant data.

Thanks.

EDIT: I should have noted earlier that I can get other demo projects working (Shooter Game and Swing Ninja). However, they exhibit some strange behaviour such as this Vine

So from what I can tell it looks like your engine is trying to access something that doesn’t exist, or it doesn’t have permission to access.

Specifically it states in the engine crash log that when you tried to load the game, it didn’t exist, so I’m guessing that it simply ran into some issues for the files that are fundamental to the project, but not the engine. Am I right in assuming you can open up 4.5.0 with no problems whatsoever? If not, read on. If so, re-install.

When you tried to launch the game, it recognized a lot of things as valid,but then somewhere after OpenGL came up, it ran into issues with DerivedDataCache. You mentiioned you tried removing it, but I don’t really know if that helps your issue. I think you should recognize whether or not you had any custom code whatsoever or methods that may have only worked or compiled on Windows. I’m not saying this is the case but you don’t mention if your version of UE4 is clean or not.

‘UIScaleRule = ShortestSide’ is also an issue that seems to come up. Some quick google searching relates it to some 4.5 crashlogs, but nothing concrete or any answers. My immediate guess is this is not the cause of your crash.

My first recommendation is to ensure that your video drivers are completely updated (For that weird flickering issue, as well as the big project related one), and then consider rei-nstalling the engine from scratch or verifying the engine.

After that, retry porting the project from Windows to Mac, as something may have been lost in the process. Also be sure to include all the necessary files when compiling for Mac.

Finally, I’m not sure if Macintosh has something similar to Admin accounts however with that being said, ensure that you’re running the engine as Admin. Like I said, I don’t use Macs so I don’t even know if that’s an issue that comes up.

Sorry if I couldn’t help more.

Edit: I asked a friend for some advice on the matter, and he suggests that the issue arises during the call stack when the engine tries to call FAvfMediaPlayer::Tick(float).

There are no results when I look that up, so I’m guessing it’s either a method that didn’t port over well, or a custom method you made yourself.

Edit Edit: Turns out it’s a new feature, not sure what to tell you. Might be an issue from Windows to Mac. If you can’t resolve the issue then remove the code from the project completely.

Thanks for the help!

4.5 does indeed boot up without an issue and I can start a new project without an issue. You’re probably correct in saying that something was compiled with a windows only dependency, I just need to find out what. I’m working remotely with someone else who set up the project on windows so it’s all new to me.

As far as drivers go, they’re updated during OS updates on mac, so they should be up to date. There could however be some kind of issue with Yosemite and UE4 itself, as there seems to be quite a few similar-ish issues popping up that note UE4 is being run on Yosemite.

I’ve done a complete re-install and that hasn’t fixed it unfortunately. I’m currently picking through the project and putting in assets one by one into another project to try and determine what was breaking the project.

Thanks again for the help!

Turns out the fault was a dodgy video texture mat file that was being used for a splash screen. Just removing the file has stopped the crash.

I don’t have a reason why that would cause the issue. Perhaps a codec issue or maybe dodgy encoding? I really don’t know.

No problem. Glad to see your problem was resolved!

Hi CamBaks,

Would you mind zipping and attaching the .uasset that was causing the crash so we can take a look? Thanks!

Hey Ben, I’ve zipped up the files that were causing the issue. Hope it helps.
Crashing Assets

Hi CamBaks,

Thanks for attaching the problem assets. I was able to reproduce the crash using those assets and have entered a bug report in our system (UE-4969). Thanks again!