Download

Project crash on new computer

After struggling for 19 months with my old FX9590/GTX970 setup, it was time for a new rig. (Ryzen 3900x/RTX280Ti)
Unfortunately, she no worky. First time I loaded the project, it crashed at 83% with:


Assertion failed: ShaderRef != 0 && *ShaderRef != nullptr [File:D:\Build\++UE4\Sync\Engine\Source\Runtime\RenderCore\Public\Shader.h] [Line: 1944] Failed to find shader type TGPUSkinCacheCS<0> in Platform PCD3D_SM5

Every time after that:


Unhandled Exception: EXCEPTION_ACCESS_VIOLATION reading address 0xffffffff

I’d be most grateful if someone could tell me what’s going on? On a lighter note; the game plays wonderfully on the new setup. Gone from 35FPS to 150FPS.

Cheers
Chris

Managed to narrow it down to something in the config folder. The project loads if I delete the configs.

Solved. (I think) Deleting r.SkinCache.CompileShaders=True from the DefaultEngine.ini allowed the project to boot.

Well that wasn’t a solution. Turns out I need r.SkinCache.CompileShaders=True, or it causes other problems.
I’m guessing the problem concerns skeletal/skinned meshes.

On the old computer the project loads, compiles and the resulting game plays.
If I update the engine from 4.24 to 4.25, on the old computer, It casuses artifacts on the suspect skeletal mesh.
If I move the 4.24 project files to my new computer, which is also running 4.24, The same thing happens to the skelmesh - artifacting.

I will post some images in a while.

r.SkinCache.CompileShaders needs to be active with raytracing.

This might be a shot in the dark, I’m guessing because all my failed to load problems have all been related to the spherical capture resolution. Default it is now 2048, try lowering it…

I’ll give that a try, thanks Matt.

After looking through my project, I don’t appear to have any spherical captures. I have a planar reflection capture though.

Disabling the static lighting in the engine config allows the project to start. Shaders compile. Project saves. Project reloads.
Problem is I don’t need static lighting in my openworld map. I disable the static light and boom- project will no longer load.Crashes upon loading @83%
I’ve spent 4 days on this now. Looks like I’ll have to continue development on my old rig, as I can’t dedicate any more time to solving this ridiculous problem.

EDIT: Glad I had one more crack at it.Leaving the static lighting doesn’t appear to affect the dynamic lights any, so I’ve just left it enabled.
The project cooks and builds as normal. The artifacts on the skeletal meshes are still present, but that appears to be a separate issue, which I will chase up in the animation forum.

Can I see these artefacts ? Just out of interest. ?

Good luck…

Sure. One was taken on my old rig, the other from my new.

Oldrigh_4.24.jpg

artifactmesh.jpg

I no longer have the orginal model project files for these traps, due to a failed HD, last year. If they’re corrupt I’ll have to model them again.