Project could not be compiled. Try rebuilding from source manually ERROR !Help please!

Hey. Was unsure where to post this issue; I hope I am in the right place.

I am receiving the following errors:

"The following modules are missing or built with a different engine version:
Would you like to rebuild them now?"

And this after I select yes:

"BattleTank could not be compiled. Try rebuilding from source manually."

In the build log before the error comes up and this is how it read:

Running C:/Program Files/Epic Games/UE_4.18/Engine/Binaries/DotNET/UnrealBuildTool.exe BattleTank Development Win64 -project=“C:/Users/Master/Documents/GitHub/BattleTankUnreal/BattleTank/BattleTank.uproject” -editorrecompile -progress -NoHotReloadFromIDE
Using ‘git status’ to determine working set for adaptive non-unity build.
Creating makefile for BattleTank (no existing makefile)

I’ve tried generating my visual studio files. I’ve tried re-installing visual studio. I’ve tried reverting my commits on Github - this has worked a couple of times, but then when I finish up making changes to my project (and them commiting/pushing those changes), the next time I open them, these same problems pop up again. It may have something to do with Github, but I’m really not sure how. I’ve been searching for an online solution but am yet to find one.

Any help would be greatly appreciated!


PS. I’ve been using the same Engine version the whole time, which is Unreal 4.18

u found any solutions yet?

Did you not see how old this post is?

you can find some solutions here:

I have the same issue but the project was made with blueprints