Project cannot be rebuilt

I am at a loss and I really need help. I was following a tutorial and tried to add some code to a header file that ended up crashing UE4. No problem, just fix the code then delete binaries and Intermediate folders and let it rebuild itself. But neither of my IDE’s (Rider and VS2019) will read UE4 code for this project specifically anymore. What I mean by that is it’s not recognizing header files, DeltaTime, TickType among many other things. (These errors in code happen in both IDEs for this project but I do not have this issue with any other project.) When I try to rebuild it through UE4 it tells me I need to rebuild manually but I can’t because there are all of these errors in my code within the IDE that should not be there(Everything compiled fine prior to me entering the incorrect code that caused the initial crash but I deleted all of that added code). I have no idea how to move forward, everything i’m finding is just telling me ways to rebuild from the IDE but I can’t. I’ve spent 20+ hours on this tutorial and really don’t want to lose it with only 2 hours of tutorial remaining.

Please help :frowning:

I want to also add that I tried deleting .vs, Binaries, Intermediate, saved, and the sln and tried rebuilding the VSCode. That didn’t work. I have a .idea and .vscode folder I haven’t tried deleting those but don’t want to risk messing this up further.