Project broken after copy from 4.8 to 4.9

The last few days I have been trying to resolve a bit of an issue, a big issue in fact.
I have been looking everywhere on answerhub, the forums, google has given me many pathways, none of which have a solution.

What I am trying to do, is simply compile my 4.9 version of the project, with zero changes from my 4.8 version.

  • First, to make sure my 4.8 version is working, I compile and it succeeds, no problem.

  • Then I go to the Epic Games Launcher, launch 4.9, and open a copy of my 4.8 project in 4.9.

  • I then attempt to recompile, and I get a whole plethora of errors and other problems, but when the compile fails, the reason is unknown, which isn’t very helpful. But I assume that the errors to do with being unable to find different classes and meshes etc.

  • I attempt to “Fix up redirectors in folder” on the content folder, which takes a few minutes, but then appears to remove a few things.

  • I do the fix up redirectors in folder again, which appears to do nothing now.

  • I then try to compile again, still I have a plethora of errors, most notable are the “Can’t find file for asset” errors.

  • I then look through some of the blueprints and I am finding that nearly every blueprint cannot be compiled, nodes are disconnected, behaviour tree’s cannot find classes, even though they are definitely visible.
    The only way to fix these errors, is to go through every single blueprint it seems, find the errors, which in most cases are “cast to” nodes that have now become “Bad Node” due to classes that can’t seem to be found.
    I have a LOT of blueprints and there is no way I want to go through every single blueprint to find these little errors.

And i’m not even sure that by going through all of the blueprints, that the problem would be solved.

I even attempted to compile the VR shootout demo, and the compile failed with unknown reason on that too :frowning:

I have made blank template projects in 4.9 and compiled those with zero problems however.

I did try to delete blueprints one by one, to narrow the problem down, but since almost all of the blueprints had missing references in them, I had to delete all blueprints before it would compile. And since my game is all blueprints, I pretty much had to delete the entire game before it would compile, lol.

I just attempted to copy the entire contents folder to a blank project, still no success.

I then removed the project, created another blank one, copied contents across, went into any of the blueprints that I could find that had errors in them, re-compiled. Some had errors because another blueprint wasn’t being recognized, so the Bad Node’s that kept showing up were on cast to nodes that previously worked. I had to go to the class blueprint that I was trying to cast to, and click compile again, even though it had zero errors and was already showing as compiled, and then had to go back to the project with the bad node and re-do the cast node.
(if that makes any sense).

Still, even by doing this (I found about 4 blueprints so far that had bad nodes in them), the build compile failed :frowning:

Can you share you project files?

I also just want to mention that upon copying the project to 4.9, there are 247 Load errors that suddenly appear, they are all “ActiveClassRedirects contains a collision with multiple redirectors for old class named ________” (where blank underline is names of what looks like internal engine classes).

I can provide logs for the game, but I won’t be providing the project itself (if I have to, it will be directly with an epic games staff member since it is a rather large game prototype that I’ve been working on since february, not publically).

What I will do though, is share a log of both the successfully built 4.8 version.

And a log of the unsuccessful 4.9 version without any modification, just a straight copied project from the launcher.

Lastly is a log that is unsuccessful, after “Fix up redirectors in folder” is done on the main contents folder.

However, upon checking, these .txt files are larger than the maximum attachment file size, so I have to put them into a .rar file:

[link text][1]
[1]: 57718-compileerrorlogsotreum.rar (323 KB)

I got an email to say Doug Wilson responded, but I can’t see his response here.

He says:
“Hey Otreum-
When you make the copy of the project in 4.9 does it open in the editor properly or does it fail to open as well as compile? What are the Visual Studio errors when the 4.9 version fails to compile? If possible, could you send me a copy of the 4.8 project that I can upgrade to 4.9 to test myself? To do this privately you can upload the project to dropbox and then send me a private message on the forums with a link to download the project.
Cheers
Doug Wilson”

To answer Dougs question, the project can open perfectly ok inside of the editor, I can run around, and play/test it like normal.
The project is 100% blueprints, I don’t do any C++ work (yet), so as far as Visual Studio errors go, I really couldn’t say.

I did a bunch of trouble-shooting since posting this query on AnswerHub, and eventually looked at the big glaring error that says:
[2015.09.09-00.51.19:506][ 0]LogInitisplay: LogProperty:Error: UStructProperty::Serialize Loading: Property ‘StructProperty /Game/MyContent/Blueprints/Vehicles/PowerLoaderAnimBP.PowerLoaderAnimBP_C:AnimGraphNode_ModifyBone_2B24B5804DB962B0535FBCB59EA39E5A’. Unknown structure.

This is within a vehicle blueprint animation, I had to delete a Transform (modify) bone node and compiled with success, which was really bizarre since it works in 4.8.

I feel kind of embarrassed that I didn’t look at that sooner, I thought I already tried it and it failed, but I guess I didn’t. (Honestly, when I looked at the error log, I didn’t know where to start).

Is there a way to get the error log to show more than just the first 50 errors?
I checked at the actual log files themselves, but they just show what the Output log shows.

Thanks Doug for taking the time to respond, and doing so, in such a quick time, hopefully the project file I sent you will have something that can help epic games in making the engine more bug free.

Cheers! :slight_smile:

Hey Otreum,

My original post was based on the false assumption that you were working with a code project. I removed that post once I realized I was going in the wrong direction with my questions but I’m glad to hear that you were able to find the solution.