Progress Bar Set Percent Wrong

Than i read 1.0 or another percent from variable it sets wrong. Always ~ 0.2. But if i will set on input 1.0 or 0.8 it will set good. I suppose it is a bug



We’ve recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.


Your message is very hard to understand, consider rewriting it a bit.

So… what are your Health and Max Health values. I’m 99.98% sure it’s the math that fails here.

Health & Max health = 100. I checked this. It’s very interesting because hp/maxhp = 1, but if i will put it in percent input it’s always ~ 0.2 in progress bar. I tried to truncate in and input integer. Truncate returns 1 integer and it’s == True Boolean but if i will input this integer 1 like percent it sets 0. I created this code some weeks ago and it worked right. But after this time, it doesn’t work though i didn’t change something in that code.

I found solution. It’s bug because of wrong max hp replication. On client it was 500. On server 0.2 And i suppose i called this function wrong.