Download

Product Viewer Template vs. Sequencer

Hello there,

I’m pretty new to Unreal, though I’ve gone through a few tutorials and mini projects to be somewhat competent.

The problem is I’m trying to use sequencer with a cinematic camera to output image sequences of an interior, but the product viewer templates “start menu” is in front of the camera through the whole sequence when rendering the output. I want to keep the menu for the project, but somehow disable it when rendering the output. I’m still new to game mode blueprints but I have a feeling my answer is in using a game mode override in the rendering output window. Any thoughts?

Bonus question: High Res Screen Shot outputs render passes (Ambient Occlusion, Diffuse, etc.). Can sequencer do the same beyond jpg. image sequences?

I know it’s not a solution, but I solved by copying the project and deleting the blueprint part of the product viewer to make the videos

I’ll try that, but in the end I’d like to keep the blueprint so I can make an all-around render output/interactive project.

The ProductViewer_Collector BP has a VR Preview checkbox that drives this part of the Event Graph. Currently it skips the menu and directly calls function “Spawn VR”. You could try redirecting this to function “Spawn Desktop or Mobile” instead. You could add another branch/variable if you wanted to maintain the Spawn VR capability. Not sure if skipping the Start Menu section of the BP will affect any of your other functionality.

Appreciate the suggestion, though I haven’t figured that route yet, but I’m sure it’s possible for someone who knows blueprints better than I do.

I DID find a coincidental workaround! When outputting a render from sequencer, you set the output to custom render pass (which coincidentally answers my bonus question of render passes!) and render .jpg sequences that bypass the template blur menu. It also probably has to do with the fact that I created a cinematic camera and added it to the sequencer rather than have the sequence spawn a camera to animate.

All and all, worked! But if anyone can figure a process/blueprint to bypass the starting menu, that would still be good to know.