Download

Product viewer template not working with Vive in 4.21?

We have a Vive connected and we tried on two different computers to try to get the Product Viewer template to work in VR in 4.21.

  1. If we Play as stand alone, the product viewer has a Start button, but no obvious way to enable a VR headset, and it’s not enabled automatically by having SteamVR running.
  2. If we Play in VR Preview mode, we can’t see anything because the view is blocked by the splash screen:
  3. If we throw a Product Viewer VR Pawn, or even Product Viewer Vive Pawn into the scene, only Oculus controllers show up, and we can’t teleport.
  4. To get the VR running at all, we have to remove the Product Viewer Collector (odd name, btw… why not Product Viewer Manager?) and then we get the following error messages:

    (Note the spelling error.)
    Capture2.PNG

Does anyone else get this?

EDIT: Also, for learning purposes, it was super weird to not have a default player/camera in the scene, but rather find out it’s spawned by that awkwardly named “collector”. This makes it really difficult to imagine how to add custom menus to each controller. Has anyone managed to place actual controller actors in the scene and have them show up as Vive controllers?

Since nobody is mentioning this anywhere else, and nobody is replying here, is there a way I can error check this?

I don’t see why an Oculus controller would spawn on two different Vive setups.

Hey, this looks like familiar problem and the solution should be to check this checkbox in the “ProductViewer_Collector” blueprint Details panel:

Screenshot_2.png
The controller default mesh is Oculus on this blueprint but it does change them to Vive meshes when the pawn is spawned properly.

Yes, Kijali is right – this is mentioned in the docs for the template. And don’t forget to uncheck that VR Preview button again before you package your project!

Thank you for pointing this out!

Interesting to note that not even the person who held the the “Product Configurator In Blueprint” session at Unreal Enterprise Academy last week knew this when I asked him.

And I couldn’t figure this out either by just looking at the Blueprint. Why doesn’t it handle this completely seamlessly? I mean, Unreal can surely detect if a VR headset is connected and running or not? Why do I have to make one package for VR and one for desktop?

I hope this will be improved upon in the future. Seems like a really unnecessary step, and again, confusing since VR actually works even without that checkbox, only you get the wrong controllers and no way to remove the splash screen.

Just to be clear, when you package your project, you make a single package that works for both VR and desktop seamlessly. In this case, you use the splash screen menu to choose your control mode.

This VR Preview setting is only for use when you’re previewing inside the Editor and you want to tell the Editor, “hey, launch me in VR mode as if I pressed the VR button in the splash screen”.

I agree with you that it should be seamless so that when you press the Preview in VR button in the toolbar, and you have a VR device connected, it would handle that automatically.