Product Activation Failed: Error E150-1041

you managed to solve the problem?

When attempting to install unreal engine 4 from the Epic Games Launcher, I get an error message saying that product activation has failed with error code E150-1041

I’m getting the same error when trying to purchase a plugin as well.

Same Someone please help!!

you managed to solve the problem?

I have the same problem, why?

same tings :frowning:
Must be server related boys gonna have to just wait it out

I’m having the same problem… The funny thing is the only things I can find on the error E150-1041 has been posted in the last 40 minutes… nothing else has come up about it before. Tarj12 might be right about waiting it out… ugh

We are noble pioneers into the mysterious lands of E150-1041!

Quite so! haha

I’m dealing with exactly the same issue of you all guys. Just as JoJo-Trass said, on my case, I’ve just find out any publications about it on the last few minuts as well… I do think we need to w8, cuz it seems something really bad has happened and this is not a much specific error, since it’s happening in many systems…

There’s another thread on the same issue… zkiller555 might be right.

Same issue here. But also receive a network error when trying to purchase in the marketplace

I am having this issue as well. I just installed the Epic Launcher, and tried to install the engine, then I got this Product Activation Error E150-1041 4/5/18 9:24pm EST.

im just trying to install fortnite and im hit with the same error

youre giving me hope bless you

this error is similar to the one we are having now

Same error here

I bet if we all sent an email it would get solved faster or at least be sure to get their attention…

Epic Games Launcher need run as administrator

i use windows 10