Procedural Mesh Component (Slice) Bugs

Screen capture - 887039f5b238f98ab0c46d49920ab8ae - Gyazo <— Please watch that, identical BPs…only one slices 80% of the time? (Granted, could be doing this whole set up wrong)

Alright, so let’s get the first big issue, Screenshot - 3de7f4f7cc97c59aa9cfb0334dc0382f - Gyazo Happens when you place an actor with a Procedural Mesh Component attached. Doesn’t happen when you add it manually in a graph. BUT, if you do that, then this next big problem happens… Adding to graph, does NOT allow you to disable Use Complex as Simple Collision. That’s the only way we’ve been able to get this working. If that’s not the intended route, then alright. But submitting “working” project also. You’ll see that only one works while the other two do not. Not sure what’s going on, but it’s really annoying not getting this to work seeing how others are seemingly getting this feature to work somehow.

Oh, and how do you have a getter for this: Screenshot - 650be7aa19d0c4f50cebd32a3ac129a6 - Gyazo but NOT a setter? This would solve one of the issues right away.

Hi Victor,

It seems that you aren’t setting plane position correctly. This is calculated in world space so to get the mesh to always slice get world location of your mesh component.(see screenshot)

Regarding the level not saving, yes, this is a major bug and I have written a report here: Unreal Engine Issues and Bug Tracker (UE-35280)

Finally, being able to disable Use Complex as Simple collision sounds like a feature request and I will file one shortly.
Thank you for submitting this bug report! You provided a lot of useful information that made the investigation go a lot smoother.