Download

Procedural Mesh Component does not draw in game.

I’m feeding some of my own data to the procmesh component, when I convert to static mesh, the mesh is shown looking as expected but it does not appear in the viewport at all.

Are there any obvious hiccups some of you more experienced users can think of because I can’t really debug what’s going on in the plugin very easily.

I’ve set and checked visibility of the mesh section, I’ve also tried applying various materials while the game and no results.

Check your winding there’s a note about it in the alt+ctrl, reduce it down to the first triangle to help solve the problem

Do you create your ProceduralMeshComponent in runtime or its already attached component on one of the actor present on map?

If it is a winding issue, shouldn’t that just invert the face normal? Also, shouldn’t that mean that extracting a staticmesh from it shouldn’t work? I’ll read the note if I can find it.

Edit: What do you actually mean by alt+ctrl, I thought you meant a VS shortcut but I can’t produce anything that looks like a note

I create the mesh component at runtime, and attach it to an actor at runtime too. I attach it before I create a mesh section if that helps?

Is there some sort of update children function I need to call on the parent actor that I don’t know about? I tried to call SetMeshSectionVisible but to no avail.

How are you converting to static mesh?

After you create your ProceduralMeshComponent - do you register the component? Otherwise it may get destroyed immediately after creation. I struggled with this issue myself when creating SplineMeshComponents at runtime.

20200219-10_52_08.jpg

I’m just using that button in the editor, and opening using the static mesh viewer. It seems to be normal when extracted that way.

I’m sure I read somewhere that components now register themselves as of 4.something but it can’t hurt to try.

Edit: I’ll be a monkey’s uncle. That was it. May the person who wrote that about RegisterComponent be burned to a crisp for their lies.

I’m glad I could help, was struggling with this issue once as well :slight_smile: