Download

Procedural Generation "Accessed None" error

I have great history with the Accessed none error, and I still don’t understand how to set a reference after god knows how many people tried to explain it to me. but at least here I have an idea where the problem is. I used this video and followed the tutorial, bit confusing but I think I get the gist of it. nothing some practice can’t be good at. Then the errors.
Screen Shot 2021-08-28 at 4.18.18 PM|690x375
So those are my errors, the following are my blueprints.

I do think I know what the problem is, the get level streaming node, but no idea how to make it work. Any help or input is appreciated.

also wouldn’t it be great if unreal let me post multiple pictures at the same time hahaha that’d be crazy

moving on up

Oh, just watched the video. It worked for me:

Make sure:

  1. You actually have streaming levels:
    image
  2. The names are correct

All the names are correct, and I at least wrote get streaming level. In the far left of my blueprints you could see it. If it’s not the names, then how do I make sure they’re “streaming levels”? And at the same time what even are those

well actually I tried to do what you did exactly, and it doesn’t show any errors but loads nothing. its weird. I think the problem is the create instance node or the streaming level node. im new to UE4 though so idk

I fixed it by making the get streaming level the target for the level setting values. but of course, there’s a problem…


it just loads all the levels where they’re at, and not showing up as a grid. really wish this could just work right lol

That’s because you’re no longer creating instances of them, show it’s only showing one of them. You need to use “Create Instance” again.

Funny enough, the problem is the name you gave to the instance: the name can’t have a space in it; having a space in it made the game crash for me.

This post was flagged by the community and is temporarily hidden.

when you do that it comes out to the accessed none errors like it always does.

Well I just recreated the rest of it without the grid part and it worked:


So I don’t know what’s wrong. Maybe it’s the version, but I doubt it. Mine is 4.20.

This post was flagged by the community and is temporarily hidden.

Good it finally generates. If you copied my code exactly, every instance spawns 100 units higher each time, so it was just meant for a test. Just put in the grid code now.

Well it looks like it’s choosing them randomly, the chairs aren’t on all the planes. Every time you play the game, you should get different results because it’s random.

check my edits. it gives me a limited amount of edits per hour, its ridiculous. you would think new people would be the ones who ask the most questions but you need to be on here for a year before you can send replies better.

I went ahead and recreated the entire thing:


I’ll post the project soon.

Wow, thank you

1 Like

Made on version 4.20.